[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to make Japanese Input on Debian testing work?

Salut Charles :)

Thank you very much for your kind reply!

I tried to make it work using your instructions - unfortunately without result... In the meanwhile I tried everything I did before again and - I don't have any idea why - found the following working for me this time:

scim -d
XMODIFIERS=@im=SCIM GTK_IM_MODULE="scim" LANG=ja_JP.utf8 LC_CTYPE=ja_JP.utf8 LANGUAGE=ja_JP.utf8 /usr/lib/openoffice/program/swriter

As far as I remember I tried the same thing yesterday about 10 times - without result. But for some reason (probably thanks to all those things I installed following all kind of howtos) it is working now...

I wrote a little script to make things easyer:

mkdir -p ~/bin
cat > ~/bin/joowriter <<'FIN'
#!/usr/bin/env bash

# setting Japanese utf8 locale
export LANG=$locale
export LANGUAGE=$locale
export LC_CTYPE=$locale

# using scim as input method
export GTK_IM_MODULE="scim"

# start scim if not already running
if [ -z "$(ps -A | grep -i scim)" ]; then
 scim -d &> /dev/null &

# start OpenOffice writer
oowriter &

# fin.
chmod 755 ~/bin/joowriter

I hope one way will work for some future users at least - yours or the latter one... Probably chances are not very high though looking at all those different howtos on the net...

Best wishes from Tokyo and have a nice day (in Wako?) also :)

--- by the way, I didn't try Firefox and Thunderbird for the time being...

Charles Plessy wrote:
Le Wed, Nov 08, 2006 at 09:53:39AM +0900, Dietrich Bollmann a écrit :
I tried to use OpenOffice with scim and uim but couldn't activate the
Japanese input method in OpenOffice. Control-Space didn't work,
the context menu wouldn't have any entry for the input method and
I was not able to configure another Shortcut when I tried to do so
using the scim configuration tool.

Dear Dietrich,

I had a similar problem with firefox and thunderbird, until one
explained me that some crucial environment variables were needed:


Now if you start OpenOffice from the command line within a shell after
these environment variables have been exported, and after uim-xim has
been started, things should work. The uim-toolbar-gtk-systray may be
helpful too.

My problem was that I had everything in my .xsession, but I was not
aware that my login manager was ignoring this file at startup.

I am using Anthy, so I guess that you would have to apt-get install
uim-anthy to make the input work in OpenOffice whith the method I am

Have a nice day,

Reply to: