[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: suddenly boot problems - unable to mount root FS

hi christoph and thanks for your response! my answers between your lines ...

Hi Jens,

Am 11.07.2008 um 20:12 schrieb W4/Webmaster:

a server which was running for two years now without any problems doesn't boot anymore after energy-problem. crashed down, because usv was defekt.

first i thought, the harddisk is bad. starting the server with a live-cd (knoppix) works. fsck of the two partitions hda1 (root) and hda3 (data) said clean.

i i try to boot the system, i get the following error:

Kernel panic - not syncing : VFS: unable to mount root FS on unknown-block (3,1)

Looks like the bootloader is misconfigured.

i dont think so. it looks pretty good and nothing changed!

To fix, just boot from Live-CD, mount the disk, chroot into it and check the bootloader's settings.

yes, i did. no changes since installation and no changes since fallout.

Or, at a boot command line, add root=/dev/hda1 to the parameters, or in grub: root (hd0,0).

i did both things you proposed. no changes, same error message when booting!

startscripts in /etc/rc... can not be executed.

Do you mean you can't run them when booting from cd?

yes, it works! but only if i boot from cd and mount manually this two partitions. i dpnt know for sure - but in my opinon it tries to start this from cd/dvd. and there is not the root fs!? :(

the harddrive is the master on the first ide - channel. dvd-drive is master at the second ide-channel. ide-drivers are built in the kernel (no module).

in my opinion, the system tries to start from the dvd-drive -> (3,1). so i thought, i am very clever and changed hdd and dvd. if i try to boot with the devices changed, i get the folowing error ->

Kernel panic - not syncing : VFS: unable to mount root FS on unknown-block (0,0)

I'm not so sure what these numbers really mean: why did it change to (0,0) and not (0,1), when it was (3,1) in the first place?

i really dont know! thats one of the questions - but the only sensefull response for me ;) i think - but i dont know for sure. maybe here is anybody who can explain?!

nice, it tries to start again from / on dvd. we didn't change anything on this machine. no updates, installations, ... it is just running in an intranet as a local server.

is here anybody who can help me or has any idea how to get this system wirking again? by the way - it is debian sarge.

thx for any idea and/or hint for a solution!


Hope that helps a bit.

thank you for your response, chris. but sorry, i tried all of your ideas and nothing did help!

so guys ... further ... if anybody has an idea - please let me know! ;)



Best regards,

Christof Glaser


Reply to: