[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Weird routing issue



On Thursday 25 March 2004 14:10, Brian May wrote:
> >>>>> "Michael" == Michael Loftis <mloftis@modwest.com> writes:
>
>     Michael> netstat -rn output on the box (.7?) having issues.
>
> # netstat -rn | grep '^192\.168\.0'
> 192.168.0.0     0.0.0.0         255.255.255.0   U        40 0 0 eth0
> 192.168.0.0     192.168.0.8     255.255.0.0     UG       40 0 0 eth0

> Hmmm... Actually it would have to be more complicated then that as it
> seems to be sensitive to the Ethernet adaptor (or address), otherwise
> it would work after changing the IP address. I had to also route via
> the other system too.

It must be an arp issue.

Either a switch is impeding arp (via a VLAN or locking of ports or similar) or 
the bridging equipment is just not bridging for machines other than the one 
that is working. From your original email you indicated an arp response on 
the machine that worked (.8). Have you tried putting in a static arp entry on 
the machine to .5 on .7? ie:

# arp -s 192.168.0.5 0:50:73:68:a4:22

See if you get any pings...

t

PS: a note regarding switches locking ports : sometimes switches will lock 
down a port if they see the IP address change, this is a security mode that 
is usually off by default and is only available on fairly intelligent 
switches. I just thought I'd raise it as it might be relevant.
-- 
GPG: http://n12turbo.com/tarragon/public.key



Reply to: