[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

PCMCIA questions, re: Cisco/Samsung autonegotiation

we have a cisco 7206, and a Samsung 10/100 managed switch.
the 7026 has a fastethernet 100MBPS port.
we are seeing losses of 1 to 8% when pinging the router.
I can't find errors in the router configs, its set to full duplex 100mbps.
the switch  however doesn't show a full duplex light,
shoudl I change the switch port and tell it to be full duplex?
I can ping cleanly thru the switch from host to host but host to router.
If I move the port for the router the losses follow
we see input errors and crc errors on the fastethernet0/0 port.
some giants also.

Assuming that you've tried changing the cable, read on. :) This information comes from both personal experience and the guys down the aisle from me that support IOS switches (I'm in the Cisco TAC).

Ethernet auto-negotiation requires that both sides be set to auto. You may run into some equipment that can figure it out and set the right speed and duplex every time, but in general you won't end up with full duplex if you hardset one side and leave the other on auto, because the side with auto will never see the negotiation signal from the other side. It will then try 10 half and 100 half, and when it ends up with a connection that works, set its speed.

It's always best to hardset speed and duplex on both switches and NICs unless it's a port that hasn't been permanently assigned, or that has different equipment plugged in on a regular basis. Your connections will come up right every time, and you will avoid problems with certain NICs and switch software that continue to try and renegotiate the terms, and therefore interrupt connectivity. The 3Com NIC in my PC comes to mind... I'm considering Netgear for everything but PCMCIA, where I'll stick with Linksys.

Now that I've brought up PCMCIA network cards - my Linksys CardBus NIC (tulip) works great under 2.2 kernels, but I cannot get it for the life of me to work in the 2.4.0 test kernels - even with ac8, ac9, or ac10 patches. I just got the laptop, and I haven't tried any of the 2.3 kernels.

If I compile fully modular PCMCIA support into the kernel, the pcmcia source fails the first compile, but compiles the second time. It doesn't work on reboot - after a moment a message appears about an error when trying to reset slot 0.

If I compile the core PCMCIA support into the kernel, and either make the actual hardware support modular or compiled-in, the pcmcia source will compile every time. On reboot it beeps and lights up the dongle, but then does a low beep, indicating an error. Running "ifconfig -a" shows no eth0. If I leave PCMCIA support out of the kernel, I can't get the pcmcia source to compile, with either 3.1.14 or 3.1.15 versions. It bombs within the first three .c files every time, and the problem has eluded my mediocre skills with C.

I would just stick with 2.2.xx, except that the via82c686 audio support doesn't work in that kernel - it tries to load the driver in some kind of soundblaster compatibility mode, and fails. If it helps anyone, the laptop is a Compaq Presario 1200, model XL119. Other than the fact that I can't get sound and network to work at the same time, it's a great little machine.

Does anyone have any suggestions on that? This may not be the right place for the question, but I figured some people might have a solution handy. :)


Reply to: