[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Local Admin question

Hash: SHA1

[Apologies if you get this twice --- I posted the other copy from the
wrong email account. Hopefully the Debian servers should have rejected
it, but you never know. This one's also slightly updated.]

I have the same problem as the OP --- I'm in Administrators but don't
have access to Administrator --- and tried your suggestion. Using both
tricks I can get a login as uid=197108. However, actually doing the
installation fails.

Note that this is done without any of the hotfixes, because the hotfix
website keeps reporting technical errors when I try to download things.
(Is there an alternate source for these? Preferably a combined patch
with all relevant hotfixes?)

(a) I get failures during debootstrap due to not being able to find
chroot. I added /usr/sbin to my path (which wasn't there by default) and
tried again.

(b) I get more chroot errors:

I: Installing core packages...
W: Failure trying to run: chroot // dpkg --force-depends --install
W: Failure trying to run: chroot // dpkg --force-depends --install

However, the installation appears to proceed and I can't find anything
in debootstrap.log.

(c) After the unpacking stage I get this:

I: Configuring debconf-english...
W: Failure while configuring base packages.
W: Failure while configuring base packages.
W: Failure while configuring base packages.
W: Failure while configuring base packages.
W: Failure while configuring base packages.
I: Base system installed successfully.

Looking at the debootstrap.log I see lots of dependency errors, mostly
complaining about missing ms-libc3.5.

Assuming that I now had at least a partial Debian installation, I
proceeded with the next steps to get apt up and running; to my total
surprise, this worked flawlessly, and the upgrade stage installed and
fixed the missing packages.

So I now think I have a working Debian --- which is extremely cool. Is
there anything I can do to check that the Administrator workaround has
actually worked properly and gotten all the file permissions correct? I
do notice that after installing openssh-client, it only actually *works*
from Administrator; running it as me produces:

PRIV_END: seteuid: Network is down

Incidentally, one minor bug report: the setup script doesn't like being
run from a path containing spaces...

- --
David Given

Version: GnuPG v1.4.9 (Cygwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


Reply to: