[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: Local Admin question

I have the same problem as the OP --- I'm in Administrators but don't
have access to Administrator --- and tried your suggestion. Using both
tricks I can get a login as uid=197108. However, actually doing the
installation fails.

Note that this is done without any of the hotfixes, because the hotfix
website keeps reporting technical errors when I try to download things.
(Is there an alternate source for these? Preferably a combined patch
with all relevant hotfixes?)

(a) I get failures during debootstrap due to not being able to find
chroot. I added /usr/sbin to my path (which wasn't there by default) and
tried again.

(b) I get more chroot errors:

I: Installing core packages...
W: Failure trying to run: chroot // dpkg --force-depends --install
W: Failure trying to run: chroot // dpkg --force-depends --install

However, the installation appears to proceed and I can't find anything
in debootstrap.log.

(c) After the unpacking stage I get this:

I: Configuring debconf-english...
W: Failure while configuring base packages.
W: Failure while configuring base packages.
W: Failure while configuring base packages.
W: Failure while configuring base packages.
W: Failure while configuring base packages.
I: Base system installed successfully.

Looking at the debootstrap.log I see lots of dependency errors, mostly
complaining about missing ms-libc3.5.

Assuming that I now had at least a partial Debian installation, I
proceeded with the next steps to get apt up and running; to my total
surprise, this worked flawlessly, and the upgrade stage installed and
fixed the missing packages.

So I now think I have a working Debian --- extremely cool. Is there
anything I can do to check that the Administrator workaround has
actually worked properly and gotten all the file permissions correct?

Incidentally, one minor bug report: the setup script doesn't like being
run from a path containing spaces...

Software Engineer
Antix Labs Ltd
Atlantic House, Imperial Way, Reading, Berkshire RG2 0TD, England.

E: david.given@antixlabs.com

T: +44 (0)118 357 0 357
F: +44 (0)118 357 0 358
E: info@antixlabs.com
W: http://antixlabs.com/

Antix Labs is a limited company registered in England No. 6664221.
Registered Office: 4 Bearl Farm, Stocksfield, NE43 7AJ, England.

This email is confidential and intended for the use of the recipient
only. If you have received this email in error, please inform us
immediately and then delete it. Any views expressed in this message are
those of the individual sender, except where the sender specifically
states them to be the views of any organisation or employer. Unless it
specifically states otherwise, this email does not form part of a

Reply to: