[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Installation problems on ws2008

On Mon, 23 Feb 2009, ChrisTX - wrote:

Setting up base-files (4.0.2-0+interix.1) ...
ln: (share/man, /usr/local/man/man): File exists
dpkg: error processing base-files (--install):
  subprocess post-installation script returned error exit status 1
Errors were encountered while processing:

Here is the problem. Apparently they have changed the directory
structure. Or you have already created /usr/local/man, maybe by a
previous installation. Remove or rename the dir /usr/local/man and
retry. There shouldn't be these "dpkg: error ..." messages in

For the "apt-get -f install" problem: What $PATH do you have when
issuing it? It should include /usr/sbin and /sbin.
You might want to modify /etc/profile.lcl for a permanent change.
The thing is /usr/local/man is now a system file, not a directory, appareantly. However, deleting this file was one step to fix it.

I had to run su first, then export PATH=$PATH:/sbin:/usr/sbin and then it worked.

I've not that much experience with UAC systems currently. So your help
would be appreciated.

I reinstalled the SUA SDK and the SuToRoot option is described to be necessary for UAC, else root can't be impersonated. I guess my problem was due to this, I had to execute the shell as administrator per rightclick and then run su to be the real root. Quite confusing, but I guess this is the only way to get it to work.

I've experienced something else now (after the install succeeded, apt-get update and upgrade -f -V both don't do anything now as supposed),
some packages simply deny the install. I experienced this with x11-common.
It gave me really weird errors (I deleted the logs now, but it was around this way)
-t is not found
-w is not found
80 is not found
dpkg: error processing x11-common (--unpack): [ manual install/unpack with dpkg failed too ]
subprocess pre-installation script returned error exit status 3
-t is not found
-w is not found
80 is not found
subprocess post-installation script returned error exit status 3
dpkg failed with exit code (1)
[ this is done out of my memory, could be that some words are not exactly the same, but I guess the error is described ]

I couldn't cleanly do anything then, so to fix it at least it in some way, I removed the entry of the package out of dpkg manually and then ran apt-get -f install. This made at least the other packages to work again. I also noticed that the latest version for interix is according to the package list x11-common_7.3+10-0+interix.1_interix-i386.deb, but it tried to install x11-common_7.3+18-0-all.deb [again I can't tell the exact file name as of now]

Right, you shouldn't install original debian arch:all packages for which I made some necessary adaptions for interix. Put in

Package: *
Pin: release a=unreleased35
Pin-Priority: 800

That should resolve it. I'll clarify this in the INSTALL info. For other packages to install it may be necessary to use GNU coreutils programs rather than the standard interix programs. See the end of the INSTALL info.


Reply to: