[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installation problems on ws2008

On Sat, 21 Feb 2009, ChrisTX - wrote:

Hi, I've been trying to setup debian-interix for some days now, but I can't get it too install. I tried it in a VM and my real machine, both fails with the same error:

$ ksh setup
E: Invalid Release file, no valid components

I figured out so far that this error is related to sed, in the debootstrap.log I always see these lines:
/tmp/install/sed[1]: MZ?ÿÿ¸@?º´: not found
/tmp/install/sed[2]: ³ÁÃEl: not found
/tmp/install/sed[3]: syntax error: `(' unexpected
/tmp/install/sed[1]: MZ?ÿÿ¸@?º´: not found
/tmp/install/sed[2]: ³ÁÃEl: not found
/tmp/install/sed[3]: syntax error: `(' unexpected
/tmp/install/sed[1]: MZ?ÿÿ¸@?º´: not found
/tmp/install/sed[2]: ³ÁÃEl: not found
/tmp/install/sed[3]: syntax error: `(' unexpected
mv: rename ///var/lib/apt/lists/ to ///var/lib/apt/lists/.malformed: Invalid argument

Furthermore, if I replace
TMPCOMPONENTS="$(sed -n 's/Components: *//p' $reldest)"
TMPCOMPONENTS="main non-free"
then it passes the error but gives out
E: Invalid Release file, no entry for main/binary-interix-i386/Packages
instead. And so far I haven't managed it to get around this error.

I've just verified the installation on SFU 3.5 without problems. It seems to try to execute sed as a shell script. Did you download in binary mode? You should verify that you can run all the binary utilities separately from /tmp/install, i.e. md5sum, tar, sed, wget, zcat.

I don't have Windows 2008 to test with, but one question:
Are you on 32-bit or 64-bit Windows 2008?

If you are on 64-bit, there might be a shared library issue, i.e. libc.so.3.5 might not be found. In that case try copying or symlinking it to /lib.

I've tried the installation with SUA 6.0 SP1 + KB959543 on Windows Server 2008 Datacenter x86 edition and with SUA SDK options
 - Utilities -> Base Utilities
 - Interix GNU Components -> Interix GNU Utilities
 - Interix GNU SDK
I know that in the hotfix list KB959543 is recommended too for my platform, but I found it nowhere (well yeah, I could contact Microsoft, if that's required) and I guess that a fix for DST timezones won't solve my problem. Any help is appreciated, thanks in advance.

Actually, that's a bug in the script generating the html page, thanks for pointing out. I need to fix this. KB959543 is only recommended for SFU 3.5 because it contains the latest core files (posix.exe, psxdll.dll, psxrun.exe, psxss.exe). For 2008 it's optional.

For getting KB959543, I see a link "Hotfix Download Available View and request hotfix downloads" at the top of the KB article.


Reply to: