[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel 2.6, NVIDIA and 460GX

>>>>> On Wed, 29 Dec 2004 23:51:31 +0100, maschino@jouy.inra.fr said:

  Emeric> Hello, I'm running Sarge (updated daily) on a hp workstation
  Emeric> i2000. It's equipped with a nVIDIA Quadro2 Pro graphics
  Emeric> adapter. I had no problem with nVIDIA drivers 1.0-5336 and
  Emeric> 1.0-5347 with 2.4.x kernels. There's however something wrong
  Emeric> with current 2.6.x kernels. More precisely, something has
  Emeric> changed between kernel 2.6.6 and 2.6.7. With kernel 2.6.6
  Emeric> (official+2.6.6 ia64 patch or
  Emeric> kernel-image-2.6.6-1-itanium-smp package), the nVIDIA
  Emeric> drivers compile and work flawlessly. With kernel 2.6.7
  Emeric> (official+2.6.7 ia64 patch or
  Emeric> kernel-image-2.6.7-1-itanium-smp package), the nVIDIA
  Emeric> drivers compile flawlessly, but as soon as 3D hardware is
  Emeric> requested (i.e. even a simple glxinfo), my system freezes
  Emeric> and a reboot is necessary. It seems that this problem only
  Emeric> affects workstations based on the Intel 460GX chipset as I
  Emeric> have evidences of people using post-2.6.7 kernel without a
  Emeric> problem on hp workstation zx2000. Any idea what's wrong?

I already sent Emeric a message in private but I think it's useful to
send this to debian-ia64 as well for the record: I finally got around
to try an Nvidia Quadro 4 card in a Big Sur (which is basically the
same as an i2000).  The machine is also running Debian/sarge (as of
about 2 weeks ago) and has kernel v2.6.12-rc2.  Fortunately, the
Nvidia v5336 driver worked as expected in this configuration.  I tried
glxinfo, glplanet, and glmatrix, and they all worked fine.  I didn't
try earlier kernels.

The only problem I noticed is that the kernel gets stuck for a while
during PCI initialization, trying to enable a PCI device which
probably doesn't exist.  After a few seconds, that times out though
and the machine boots fine.  This issue is unrelated to the Nvidia
card as it happens even with a Matrox MGA card.

Hope this helps,


Reply to: