[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Suddenly no X-window

On Monday 29 March 2004 07:19 am, Matthew Wilcox wrote:
> On Mon, Mar 29, 2004 at 01:42:59AM -0800, Richard Harke wrote:
> > The first line is:
> > XFree86 Version 4.3.0 (Debian 4.3.0-0pre1v1.1 20030824013022
> > willy@wil.cx) I did not get X86 from the debian archive but downloaded
> > this version as a deb package from another web site.
> That looks like one I built ;-).  I would recommend upgrading to something
> a little more recent and official; I'm running 4.3.0-7 myself, though
> I haven't restarted the X server since I upgraded this box.
I believe that it is the one you built. I did go ahead and upgrade
to 4.3.0-7 but this hasn't helped.

> > In /var/log/boot is the line
> > Starting portmap daemon: portmap/sbin/portmap: relocation error:
> >    /sbin/portmap: symbol errno, version GLIBC_2.2 not defined in
> >    file libc.so.6.1 with link time reference
> >
I downloaded a new portmap and installed it with dpkg -i and
now it seems to work. At ps -A shows a portmap daemon

> > In /lib I have libc.so.6.1 as a soft link to libc-2.3.2.so
> What does dpkg --status libc6.1 |grep ^Version say?  I have 2.3.2.ds1-11
I get the same.

> > I have tried to update portmap but apt-get keeps complaining
> > about unmet dependecies
> >    kdelibs4: Depends: xbase-client but it is not going to be installed
> > E: Unmet dependencies. Try 'apt-get -f install' with no packages (or
> > specify a solution)
> >
> > I have tried that and doesn't change anything.
I finally got the newer xbase-clients to install. With all the warnings
from the kernel, a lot of stuff was going off-screen before I could read
it. Seems it didn't like the presence of a particular file.
> Are you sure it doesn't say "xbase-clients"?  What version does "apt-cache
> show kdelibs4" say?  I see 4:3.2.1-1 here which depends on xbase-clients.
I get the same
> Have you tried "apt-get update" recently?
More than once
I am still stuck. There are no errors in XFree86.0.log
ksplash and ksmserver report unable to connect
This is after _X11TransOpen: Unable to find transport for local

Also, kreadconfig segfaults though that doesn't seem to be

Reply to: