[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Suddenly no X-window

The portmapper is not running so I can't get my usual NFS
mount. This will make it rather tedious to get XFree86.0.log
over to my mail machine.
The first line is:
XFree86 Version 4.3.0 (Debian 4.3.0-0pre1v1.1 20030824013022 willy@wil.cx)
I did not get X86 from the debian archive but downloaded this version as
a deb package from another web site.

In /var/log/boot is the line
Starting portmap daemon: portmap/sbin/portmap: relocation error: 
   /sbin/portmap: symbol errno, version GLIBC_2.2 not defined in
   file libc.so.6.1 with link time reference

In /lib I have libc.so.6.1 as a soft link to libc-2.3.2.so

I have tried to update portmap but apt-get keeps complaining
about unmet dependecies
   kdelibs4: Depends: xbase-client but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or
specify a solution)

I have tried that and doesn't change anything.


On Monday 29 March 2004 12:03 am, Duraid Madina wrote:
> Can you tell us which version of glibc and XFree86 you have? Your
> complete /var/log/XFree86.0.log might be useful too.
> (David: perhaps some piece of 4.4 has been pulled by the debian X guys
> into their 4.3?)
> 	Duraid
> Richard Harke wrote:
> > I see the NVIDIA logo then it tries to change but immediately
> > quits, that is it switches back to VGA terminal mode
> >
> > The lines I gave were from the messages on screen
> > They were not in XFree86.0.log because they are from KDE and
> > not from X
> > Effectively, X only runs long enough for the Nvidia logo
> > to display
> >
> > On Sunday 28 March 2004 11:15 pm, Duraid Madina wrote:
> >>What precisely do you mean by "X starts, but KDE will not run?" I'm
> >>assuming:
> >>
> >>- You see the NVIDIA splash screen (logo on white)
> >>- This screen changes to some other screen (presumably a login screen)
> >>- KDE tries to do something, and this doesn't work (from what you've
> >>pasted, it looks like it crashes the X server?)
> >>
> >>Is this right?
> >>
> >>A bit puzzled,
> >>
> >>	Duraid
> >>
> >>Richard Harke wrote:
> >>>On Friday 26 March 2004 01:57 pm, David Mosberger wrote:
> >>>>>>>>>On Fri, 26 Mar 2004 19:36:55 +1100, Duraid Madina
> >>>>>>>>><duraid@octopus.com.au> said:
> >>>>
> >>>> Duraid> You'll probably want to use a newer nvidia driver (from
> >>>> Duraid> nvidia.com) or move libc back down. I don't think you have
> >>>> Duraid> any other choices.
> >>>>
> >>>>A word of warning with the nvidia driver: it's important to use the
> >>>>driver with a "matching" XFree86 server.  AFAIK, the current nvidia
> >>>>drivers work with all version of XFree86 v4.3.x, but NOT with v4.4.x.
> >>>>Apparently, there is some version-checking support in the X server
> >>>>which could detect such mismatches, but the nvidia driver doesn't seem
> >>>>to do that and as a result, it will load into XFree86 v4.4.xx just
> >>>>fine, except that it will then sooner or later crash with a segfault.
> >>>>
> >>>>	--david
> >>>
> >>>Well, I went to a newer nvidia driver, 1.0-5336
> >>>(NVIDIA-Linux-ia64-1.0-5336-pkg1.run  there was also a "pkg0"
> >>>version in the ftp archive, but I guess that was an oops)
> >>>
> >>>Now X starts but KDE will not run
> >>>
> >>>(II) Initializing extension GLX
> >>>startkde: Starting up...
> >>>/usr/X11R6/bin/kde: line 143: 14986 Segmentation fault    kreadconfig
> >>>--file kpersonalizerrc --group General --key FirstLogin --default true
> >>>--type bool
> >>>_X11TransOpen: Unable to find transport for local
> >>>ksplash: cannot connect to X server :0
> >>>Warning: connect() failed:  : No such file or directory
> >>>ksmserver:  cannot connect to X server :0
> >>>startkde: Shutting down...
> >>>Warning: connect() failed:  : No such file or directory
> >>>Error: Can't contact kdeinit!
> >>>startkde: Running shutdown scripts...
> >>>startkde: Done.
> >>>
> >>>I think that the _X11TransOpen failure is the key one but I
> >>>don't understand what it means precisely.  There were
> >>>messages during boot up about "no response from
> >>>localhost" Does that mean that some demon is not running??
> >>>I can ping localhost and a lot of others. Also, ftp to nvidia and
> >>>apt-get to debian have worked fine.
> >>>
> >>>Richard Harke

Reply to: