[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems: Questions on mini-20110308.iso



I never tried DHCP but used a static IP. I did end up getting the system installed using the same ISO in question:

When I went to install the base system, as in prior attempts, the installer couldn't retrieve libc-bin. I selected "Go Back" when the error message popped up alerting me (as opposed to "Continue"). The installer retrieved the rest of the base packages, but encountered a chroot error when trying to install the base packages. I checked the (Mach?) console, and saw a bunch of errors stating that there was no user root.

Anyway, I then went back and ran "Install the base system" step again. This time it installed everything fine (including apparently downloading libc-bin), and I was able to proceed with the rest of the installation. I rebooted and was then able to boot using GRUB and logged in as root. Everything seems fine so far. (I know libc-bin installed because I manually tried to install it using apt-get and was told it was already installed).

So I guess in my prior attempts I failed to persevere!

God bless

David Hiran Watson
e: hiranwatson@gmail.com

-----Original Message-----
From: Svante Signell <svante.signell@telia.com>
Date: Fri, 18 Mar 2011 20:33:34 
To: debian-hurd maillist<debian-hurd@lists.debian.org>
Cc: Samuel Thibault<sthibault@debian.org>
Subject: Problems: Questions on mini-20110308.iso

Hi,

I've started to write down the steps to install Debian GNU/Hurd as
promised some time ago (up to and including X-windows) under Qemu, using
the Debian installer in mini-20110308.iso, and ran into a set of
problems:

After the successful install (including setting up the network with
dhcp) the final step before reboot fails:

Install GRUB bootloader on MBR: Yes
(when rebooting)
/hurd/init: Crashing system; essential task auth died
init: notifying ext2fs /dev of shutdown: notifying pfinet ... notifying
ext2fs gunzip:device:rd0 of shutdown

Reboot happens after a timeout, so it was not possible to catch all
output.

Restarting from the hard disk no network was set up, maybe dhcp-client
should be called again to get it working??

manually setting up the network with:
settrans -afg /servers/socket/2 /hurd/pfinet -i eth0 10.0.2.15 -a
10.0.2.15 -m 255.255.0.0 -g 10.0.2.3

enabled the network again. However, now ssh-server failed to start. A
second try without ssh-server chosen resulted the same problems:

apt-get install random-egd openssh-server

Now openssh fails to start, giving debug output
from ../sysdeps/posix/getaddrinfo.c:2297 assertion error from glibc (too
much to copy manually from the mach terminal, sorry).

libc0.3 version is 2.11.2-13 with the fixed libc. 

Is the fixed pfinet included in mini-20110308.iso??
Something is definitely wrong here, what?

Maybe these problems are the similar as for David Hiran Watson with
Virtualbox. In the other hand, he has problems installing the base
system, which was not the case for me. I don't know anything of dchp
support using Virtualbox, have not tried it yet.


-- 
To UNSUBSCRIBE, email to debian-hurd-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 1300476814.4839.104.camel@hp.my.own.domain">http://lists.debian.org/1300476814.4839.104.camel@hp.my.own.domain


Reply to: