[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Xorg problems


I was following instructions under
http://www.bddebian.com/~wiki/Hurd/DebianXorg, but i found myself
unable to run startx as a regular user...

But 1st thing 1st, :)...  I initially couldn't run X as root, it looks
like the /usr/bin/X is kind of broken, but I could run Xorg.  So what
I did was to move /usr/bin/X to /usr/bin/X.old, and to make a symbolic
link from /usr/bin/Xorg to /usr/bin/X.  Then I could actually run X
(which is required for startx btw) successfully as root...  I don't
know if this is a known issue, maybe it's already been addressed...

2nd weird thing is that when killing the X session, with CTRL-BkSp, I
return to the console, but the display gets weird, kind of grey and I
can't see a thing.  This is really unconfortable, but hey, I can live
with that.  I have to kill my console (again CTRL-BkSp) and start it
again.   This might be known already, I don't know...  But if there's
a work around I'd like to apply it, :).

3rd weird thing is that although the instructions talk about
xserver-common to be dpg-reconfigured, such package does not exist.
Actually instead I dpkg-reconfigured x11-common, which allow changing
from "Console Users Only" to "Anybody".  So I don't know if this will
be the cause of the issue mentioned later, or just the usage of a bad
package in the wiki, :)...

Then I set everything to run startx as root, and it worked out nice
(with fluxbox btw).  But it's said that running X under root is not
safe neither recommended.  So I went ahead and tried on my regular
user...  If I execute plane X, then I get:

Fatal server error:
Cannot move old log file ("/var/log/Xorg.0.log" to "/var/log/Xorg.0.log.old")

This was kind of expected, since X can be executed by root only I
believe...  But when running startx I get:

Fatal server error:
Cannot move old log file ("/var/log/Xorg.0.log" to "/var/log/Xorg.0.log.old")

_X11TransSocketOpenC0TSClient:  Unable to open socket for tcp
_X11TransOpen:  transport open failed for tcp/localhost:0
giving up.
xinit:  Translator died (errno 1073741925):  unable to connect to X server
xinit:  No such process (errno 1073741827):  Server error.

Of course this causes trouble, :(...  Bad thing is that I don't know
the reason since there's no log to look at, :(...  Moreover, I
supposed that by dpgk-reconfiguring x11-common this was resolved, but
obviously I was wrong...  It's supposed that startx/xinit would take
care of the proper call of X, but it seems they don't (it looks like
the regular user is directly accessing X, which I think shouldn't
happen, since root should be the one finally accessing X)...

Can anyone confirm if went through the same issues, and if there is a
work around?

Thanks a lot,


Reply to: