[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Wireless

On Nov 20, 2007 9:55 AM, Michael Banck <mbanck@debian.org> wrote:
> On Mon, Nov 19, 2007 at 08:59:29PM -0600, Javier Vasquez wrote:
> > Hi,
> >
> > [...]
> No, /etc/network/interfaces is not (yet) supported, and I don't know
> about guessnet.
> http://lists.debian.org/debian-hurd/2006/09/msg00025.html has some
> information on setting up wireless.  Feel free to put this up in the
> wiki at http://www.bddebian.com/~wiki and complement it with your
> findings.
> Michael

Cool, :)...

I have an ipw2100 inner card, which was not recognized (devprobe
eth0/eth1/... didn't work).  So no luck there...

I tried a dell trueMobile pcmcia card, which is orinoco based, and it
worked, :)...

A couple of things...

1st, I didn't find a way to use dhcp.  I have dhcp-client installed so
I supposed it'd work automagically because I set
/etc/pcmcia/network.opts with DHCP="y".  But when getting hooked with
the access point, I didn't get an IP automatically.  Then I tried the
translator socket/2 with the "-d" argument for dhcp, and it didn't
work.  So at the end I tried the same translator but specifying the
IP, the gateway, and the mask, and I got the IP then, :)...

2nd, I couldn't find the ifconfig executable, even though I have
inetutils-tools installed, which is the package supposedly providing
ifconfig.  So the only way to know if I had IP was to "ping
www.google.com", :(.

3rd, I don't know if it's because of the way I configured things (I
set DHCP="y" under network.opts, and no IP neither gateway, etc), but
I'm used to perform "ifup eth1" under linux and get hooked to the
access point with an IP at the same time, but here I had to 1st get
hooked, and then use the translator to get the IP...  Is this the
regular way?

Thanks a lot,


Reply to: