[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: blank screen after executing console command...

Actually I searched under google for "hurd console" and found
http://kerneltrap.org/node/420...  There it says:

The above six ttys are only suggestions. You might want to give or
take a few, depending on your needs.

You need the terminal description. This is not yet in the ncurses
package, because I am not finished yet. But you can download it from


Please add it with

# tic -x hurd.ti

Then you should add the terminals to ttys, so you get a login session
on them at boot time. Edit the file /etc/ttys, and add the following
lines (or similar if you made more/less ttys):

tty1    "/libexec/getty 38400"          hurd            on      secure
trusted console
tty2    "/libexec/getty 38400"          hurd            on      secure
trusted console
tty3    "/libexec/getty 38400"          hurd            on      secure
trusted console
tty4    "/libexec/getty 38400"          hurd            on      secure
trusted console
tty5    "/libexec/getty 38400"          hurd            on      secure
trusted console
tty6    "/libexec/getty 38400"          hurd            on      secure
trusted console

This is all. If you now reboot, you will get six virtual consoles with
a login prompt on each.

I didn't have to add the lines over /etc/ttys since they were there
already.  The tic command didn't show out any output, just executed
pretty quickly...  But I didn't get the expected behavior, meaning
when rebooting I never get the login prompt, neither the 6 virtual
consoles, so I didn't followed the next instruction for calling the
console since there's still something broken before that stage...

Any ideas what else I need to do?


On 5/22/05, Javier-Elias Vasquez-Vivas <jevv.cr@gmail.com> wrote:
> Hello,
> Yes, under /etc/ttys there are several ttys, between them the one you
> used as example.  When performing "ps auxww" (hoping it's same as in
> linux), then I don't see /libexec/runtty running, but the
> /libexec/runtty exists also.  I tried to call it by hand but I get (I
> know it was wrong, but at least I wanted to know availability to
> execute):
> getty[11]:  Bad syntax
> Is there something to be done to call runtty automatically so that
> console can be called?  By the way after reboot I get automatically
> logged on as root, is that the normal behavior?
> Thx,
> On 5/22/05, Stefan Siegl <ssiegl@gmx.de> wrote:
> > Hi,
> >
> > On Sat, May 21, 2005 at 09:10:53PM -0600, Javier-Elias Vasquez-Vivas wrote:
> > > Tried that, and got the same thing...  Weird thing is not getting
> > > errors after going back to mach console...  I looked for a verbose
> > > switch, but dind find any...
> > >
> > > Any other hints?
> >
> > do you have the needed getty entries in /etc/ttys, like
> > tty1    "/libexec/getty 38400"          hurd            on      secure trusted console
> > and /libexec/runttys running them (system running without
> > -s, single user mode)?
> >
> > Cheers,
> >   Stefan
> >
> > --
> > Stefan Siegl <ssiegl@gmx.de>
> > "sick nature" != "signature"
> >
> --
> Javier-Elias Vasquez-Vivas

Javier-Elias Vasquez-Vivas

Reply to: