[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Filesystem completely hosed


some time ago I reported frequent file system corruptions after
extensive write operations (installing large packages).

I thought that something might be wrong with the file system, so I
re-formatted it and then restored my GNU/Hurd installation (running
native-install etc.)

Today I tried out if anything had changed - I tried reinstalling some
large packages (which had been damaged by previous crashes): xfree-*,
tetex-bin, tetex-doc, tetex-base.

The result was truely disastrous. At some point, while initex was
running the machine froze. (No error message anywhere, probably because
I was using the new virtual consoles while the errors get displayed to
the old mach console?) Immediately before the machine froze, I
observered that ext2fs.static consumed 34% CPU time. Is this normal?

I could only pull the plug (no second computer available to telnet to my
box.). On reboot (to GNU/Hurd), fsck complained about an unexpected
inconsistency, restarted several times from the beginning and then the
machine suddenly rebooted. On trying to boot GNU/Hurd, grub informed me
that there was no such thing as /boot/gnumach.gz. So I booted GNU/Linux
and fscked again. I have a typescript of this available but even in
bzipped format it is still 49K large (uncompressed 400K).

Well, in the end, my / directory was _empty_, except for lost+found,
from where I have recovered some of the installation. (I don't have
GNU/Hurd CDs here.)

Here's the output of tune2fs -l /dev/hdc7

tune2fs 1.32 (09-Nov-2002)
Filesystem volume name:   <none>
Last mounted on:          <not available>
Filesystem UUID:          2ce47e2f-64b2-4c0c-b3c1-c14714edd6ad
Filesystem magic number:  0xEF53
Filesystem revision #:    1 (dynamic)
Filesystem features:      sparse_super
Default mount options:    (none)
Filesystem state:         not clean
Errors behavior:          Continue
Filesystem OS type:       GNU/Hurd
Inode count:              120576
Block count:              240967
Reserved block count:     12048
Free blocks:              61975
Free inodes:              81958
First block:              0
Block size:               4096
Fragment size:            4096
Blocks per group:         32768
Fragments per group:      32768
Inodes per group:         15072
Inode blocks per group:   471
Filesystem created:       Fri Feb 28 15:20:19 2003
Last mount time:          Fri Mar  7 17:58:40 2003
Last write time:          Fri Mar  7 18:22:29 2003
Mount count:              1
Maximum mount count:      31
Last checked:             Fri Mar  7 17:58:30 2003
Check interval:           15552000 (6 months)
Next check after:         Wed Sep  3 18:58:30 2003
Reserved blocks uid:      0 (user root)
Reserved blocks gid:      0 (group root)
First inode:              11
Inode size:		  128

Any hints someone?



Reply to: