[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Hurd under Bochs



Actually, I figured it out.  I was missing the -o 32256 option to
losetup.

On Wed, Sep 25, 2002 at 11:14:18PM -0400, Norbert Veber wrote:
> Hi,
> 
> I saw this message in the archives and its replies:
> http://lists.debian.org/debian-hurd/2002/debian-hurd-200205/msg00131.html
> 
> Did anyone ever get this to work?
> 
> My problem is that grub boots, but cant find any partitions on the disk
> image.
> 
> root (hd0)
> file system type unknown, using the whole disk
> root (hd0,0) 
> partition table invalid or corrupt
> find /boot/gnumach.gz
> File not found
> 
> The instructions on
> ftp://walfield.org/pub/people/ams/hurd/creating_bochs_image_for_gnu.txt
> say that you should write a partition table to the loopback device with
> fdisk, but not create any partititons.  That is what I did, but it didnt
> work.  I also tried to create a partition, but was unable to mount it to
> do the cross-install.  /dev/loop0 is the equivalent of say /dev/hda, but
> there is no loop equivalent for /dev/hda1.
> 
> What I did was:
> createdisk hurd.hd0 512
> get the grub.ext2 image, and rename it to grub.fd0
> setup the .bochsrc to refference these files
> losetup /dev/loop1 hurd.hd0
> write a partition table with fdisk (I also tried skipping this)
> mkfs -t ext2 -o hurd /dev/loop0
> mount, and run the cross-install /mnt
> unmount, losetup -d, and run /usr/lib/bochs/bochs-x (the debian wrapper
> seems broken)
> grub came up but couldnt find the kernel :(
> 
> It seems others have this problem too:
> https://listman.redhat.com/pipermail/bochs-developers/2000-June/000785.html
> 
> Supposedly people have gotten this to work, but I cant imagine how.
> 
> Any ideas?
> 
> PS. I am not subscribed to the list..

Attachment: pgpQTlc2HFUtR.pgp
Description: PGP signature


Reply to: