[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Current "dpkg on Hurd" issues

On Sat, May 18, 2002 at 03:02:58PM -0500, Adam Heath wrote:
> On Mon, 19 Feb 2001, Marcus Brinkmann wrote:
> > * Depends on sysvinit (>= 2.72), which is not available on the Hurd.
> >   A provides in some Hurd package is not good enough because dpkg can't
> >   cope with versioned dependencies on provided packages last time I checked.
> What's wrong with having an empty sysvinit?  I'm certain other packages would
> have this same issue, not just dpkg.

Actually, I would like to get my sysvinit port updated and integrated, with
the split up of the system dependent parts into a saperate package, as
posted and discussed in #43575 (2 years and 267 days old).

Almost three years ago I didn't continue to work on it because I was afraid
of getting the Depends and Replaces etc fields wrong for the smooth upgrade
from sysvinit to a sysvinit+initscripts package combination.  When I mailed
Miquel for help on this, I never received a reply, so I put this issue


`Rhubarb is no Egyptian god.' Debian http://www.debian.org brinkmd@debian.org
Marcus Brinkmann              GNU    http://www.gnu.org    marcus@gnu.org

To UNSUBSCRIBE, email to debian-hurd-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: