[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Current "dpkg on Hurd" issues



On Sat, May 18, 2002 at 03:02:58PM -0500, Adam Heath wrote:
> On Mon, 19 Feb 2001, Marcus Brinkmann wrote:
> 
> > * Depends on sysvinit (>= 2.72), which is not available on the Hurd.
> >   A provides in some Hurd package is not good enough because dpkg can't
> >   cope with versioned dependencies on provided packages last time I checked.
> 
> What's wrong with having an empty sysvinit?  I'm certain other packages would
> have this same issue, not just dpkg.

Because having 100 dummy packages is just ugly and bloat the
archive. What's wrong with fixing the actual problem? The problem here
is that we don't have versioned provides.

Jeroen Dekkers
-- 
Jabber ID: jdekkers@jabber.org  IRC ID: jeroen@openprojects
GNU supporter - http://www.gnu.org

Attachment: pgpc1DwzanF5w.pgp
Description: PGP signature


Reply to: