[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: My Hurd is back online!

Ok, I followed your instructions and got the same results.

First, I tried "make kernel-ide" which compiled ok, but
upon booting said "... Welcome to GNU Mach .... OSKit...?? ????"
and instantly went black and rebooted. I tried to hit the pause
key a few times to read it but I'm not fast enough.

Next, I did a "make kernel-floppy" which again compiled ok,
but exhibited the same instant reboot behaviour.

I am using Hurd gcc-2.95.x, updated from Debian only a few
days ago. In fact I updated the entire system while I was at

I suspect I have some bad includes or libs somewhere on my
system from previous attempts to compile oskit and/or oskit-mach.
In those exuberent days I did some bad things like copying headers
from the gnumach source into Hurd's /include/mach and whatever
it took to get make to complete a build.

The last time I cross-compiled it from linux, it would get to "user trap 2",
pause, and then reboot. If possible I would like to build natively under

Which development packages and libs should I purge and reinstall
if I want to have a clean Debian Hurd environment to build oskit-mach
from; i.e. does it have many external libs or headers which are
required for compilation? I was looking at /include/mach, /include/hurd,
and /include/oskit in particular.

I have a second machine prepped for serial debugging, except it is
an HP 9000 715/80 running Debian HPPA, and the last time I tried I
couldn't get gdb to build on it, apparently I need to make a hppa -> x86
cross-debugger, correct?

- Doug

Roland McGrath wrote:

Well, I did not make any modifications or tweaks whatsoever
to oskit-mach. I grabbed it from CVS yesterday, and did this:

   $ cd oskit-mach
   $ mkdir build
   $ cd build
   $ ../configure
   $ make
   $ cp kernel /boot

This gets you a kernel that tries every device driver compiled into the
oskit libraries.  Perhaps there is a problem with a particular driver.
Start by doing "make kernel-ide", which should give you a kernel with no
drivers but the IDE driver.  If that works ok (as far as booting and
finding that you don't have an IDE disk ;-), then move on to adding other
individual drivers.  I don't know off hand what the driver is called for
your SCSI controller.  The drivers are from Linux 2.2 and have the same
names.  So try "make kernel-ide+aha1740+" or whatever the right driver is.

Anyways, I'm happy to help utilize this nifty system to work on SMP
for Hurd by testing kernels, etc. Roland told me a long time ago that
I should use the serial debugger, but I just haven't gotten it together

Even if you are not up to taking on a lot of active debugging yourself,
having serial gdb working is the best way to gather more information you
can post here to get better help.

I think you mentioned SMP also.  If you are interested in SMP in
oskit-mach, the first thing to do is make sure the oskit's SMP support
works right on your hardware.  Try the oskit example kernels that use smp
first.  Then you can try building oskit-mach with configure --enable-smp
and get started on getting that to boot.  There is a lot of unfinished work
for the SMP oskit-mach kernel to really be usable, though.

Reply to: