[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: g++ on the hurd?



On Thu, Mar 08, 2001 at 09:07:38PM -0500, Daniel Burrows wrote:
>   It seems that libstdc++2.10-dev has a versioned dependency on libc6-dev.
> Someone should file a bug, I guess..

Well, yes. The idea was that we provide libc6-dev, but that doesn't work
with versioned stuff. Please file the bug. There is a dummy package at
alpha.gnu.org to make it installable in the interim.
 
>   I also noticed that libgtk1.2 depends on gconv-modules.  On Linux, this is
> provided by libc6; the Hurd doesn't appear to have it at all.  (libc0.2
> replaces gconv-modules, but doesn't seem to provide it)  Should someone
> ask the gtk maintainer to conditionalize his control file, or does libc0.2
> actually provide gconv-modules?

I think that might be an out of date version of libgtk1.2. It was never
updated since I uploaded it, AFAIK.
 
>   And, while I'm listing random breakage, I tried to see if X would work on
> the Hurd..no luck.  It complains that /tmp/.X11-unix has "suspicious ownership";
> that directory seems to be owned by root.daniel, whereas on my Linux system
> the ownership is root.root.  I didn't have time to investigate further,
> unfortunately.  What's weird is that it gets the bad ownership (root.daniel)
> even if I run it as root (!!)

Just fix that. I sometimes mess up horribly with the group ownerships,
because Debian sticks some g+s on my home directories, and I forget to remove
that when building packages in unusual places. 

Please check your whole filesystem with find / -group daniel (and other
spurious groups).  Find out which packages contain bogus group ownerships.
(I identified dpkg, bash and ncurses today)

>   (and of course there are very few X programs compiled..
>    if I can get X working and sort out the toolchain issues, I'll start
>    building them.. (sawfish!) )

Please! But be aware that without pthreads, gnome is no fun at all. Not sure
if sawfish uses threading. In anyway, I appreciate any efforts in this
direction.
 
>   Also, the "console users only" mode of Xwrapper is broken.  I think it
> must rely on some sort of linuxism, although I don't have any idea what it
> could be :-/

Yep, needs to be fixed. I don't know where this is checked, but I am sure we
can find out by looking at the source.
 
>   (what else..) I occasionally get lots of scary-looking error messages from
> ext2fs about (iirc) "free inode had non-zero size.." -- could it be trying to
> reallocate inodes?  That sounds bad..

A bug in linux, if you ask me. It should clear the inode size info on
filesystems owned by the Hurd. You can ignore these. If you don't ever
delete files in linux from Hurd owned partitions, you won't see it.

>   The default TERM is mach, not mach-color.  Not sure if that's
> intentional or not.

Another bug, thanks for reporting it. Will be fixed in next hurd package.

Thanks,
Marcus

-- 
`Rhubarb is no Egyptian god.' Debian http://www.debian.org brinkmd@debian.org
Marcus Brinkmann              GNU    http://www.gnu.org    marcus@gnu.org
Marcus.Brinkmann@ruhr-uni-bochum.de
http://www.marcus-brinkmann.de



Reply to: