[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Plans for X

On Mon, Oct 23, 2000 at 03:30:56AM +0200, Marcus Brinkmann wrote:
> On Sun, Oct 22, 2000 at 05:22:11PM -0700, Steve Bowman wrote:
> > I had some problems with X 3.3.6 on cvs hurd last night I was going
> > to report, then your message arrived so I'll combine that report with
> > my response....
> Okay, let's see...
> I don't know which CVS you mean, so I don't know which sources you actually
> compiled.

export CVSROOT=:pserver:anoncvs@subversions.gnu.org:/cvs
cd .../hurd
cvs update

updated 20001020 at 21:02 MST (GMT -0700)

> > The system completely hangs - at least it appears to at the console.
> > I was able to telnet in from elsewhere to see if I could get any useful
> > information.  X was already down (i.e., no X-related processes running), I
> > tried to restart X remotely and it thought another server was running
> I found out that this is related to pflocal. Killing pflocal can help.
> I don't know what the real cause is. It seems that X dying fast without
> cleanup blocks some socket in pflocal (it should probably free it itself).
> But I don't have details, and I am over this now, because my X 4.0 server
> doesn't crash anymore *grin*


> > It may be that the display or keyboard just need resetting to get the
> > console back, but I haven't figured out how to do that and had to reboot.
> > Is there a way to reset the display and keyboard after X has crashed
> > without rebooting?
> No easy way. I am sure you could hack a program to reset everything, but
> there doesn't exist one.

OK.  Reboot will do.

> > This sounds suspiciously similar to the problems you've had with X 4.x.
> Actually, only the "it thought another server was running", but yes.

Keyboard problems, too, I was thinking.

> > I'm wondering if there's something going on with the hurd that X is
> > triggering.  What's changed since the 20000921 hurd except the tunnel
> > changes?
> Nothing. I suspect that your build is broken, but I don't know which sources
> you actually compiled. No official source or repository I know of carries my
> patches.

Just hurd cvs.  The X 3.3.6 packages were the standard debs available
on the mirrors.  Your patches are just for X right, no uncommited hurd

> > Or should I be cross-compiling hurd instead of trying to
> > build natively?
> I don't think that's helping either. I am pretty sure the Hurd is sober
> except some non-critical pflocal weirdness.


> > I haven't tried restoring the old hurd yet to verify that X works again,
> > but I actually did the same thing last weekend and restoring the old
> > (0921) hurd cured X. I didn't report it yet because I wanted to rebuild
> > and reinstall hurd to make sure the problem wasn't there.  AFAICT,
> > it's a clean build except as noted in [1].
> Mmmh. If you really can verify that it works with the 0921 hurd, but not
> with your new one, I will retract what I said above :)

Verified.  X 3.3.6 works with 0921 hurd but not with cvs hurd.
I just retested X (failed), downgraded hurd, and retested X (success).
An extract of the X output log is in [1].  This time, the failed X test
went a little differently.  I didn't try to see what would happen on
a restart so I didn't get the "X is already running" error and such.
I was just trying to confirm the same X worked on 0921 and not on cvs
(20001020) hurd.

The session went like:
export LD_LIBRARY_PATH=/X11R6/lib
startx xterm > startx.log 2>&1 &	# this is the usual way I start
					# X except for the logging since
			#  I haven't bothered to figure out how to
			#  configure twm, then I start twm from the xterm.
			#  See [1] for log excerpt.
display goes blank and no response to any keyboard input
telnet in
this time, X was still running
kill <pid> wouldn't kill X
kill -QUIT did kill it
display and keyboard still gone
looked at ps output, nothing attention-grabbing like pflocal sucking up
	all memory or anything - all looked normal, just no display and
	keyboard inop

dpkg -i --force-conflicts hurd_20000921.deb
dpkg -i hurd-dev_20000921.deb

export LD_LIBRARY_PATH=/X11R6/lib
startx xterm
X works fine

> [snip]
> The current patch is attached. It is not 100%, but almost. X compiles and
> runs, but you have to -allowMouseOpenFail. That's not a problem, though,
> because the mouse handler is broken anyway. I also don't get a full display,
> but only the bottom half of my screen contains the top of the bitmap. But
> keyboard works.
> So there is something funky with the display stuff and the mouse handler.
> but apart from that, X 4.0 works fine with the patch (as far as I could test
> it with half the screen and no mouse).


> > in fact, I was going to ask for your 3.3.6
> > patches to see what kind of things I should look for and where to look
> > in 4.x to patch.
> I have something better, the 4.0 patch, see above. All of the upstream
> related changes in the 3.3.6 patch are integrated. BTW, this patch is for
> the official 401 tar file, not for the Debian source. I don't have the
> Debian source here currently, so I can't work from that. Will do it tomorrow
> or later this week. But progress is steady, and I am not concerned about the
> Debian packaging, it's not hard. What needs work is the display and mouse
> stuff, and if you can help fixing that, great. But if you don't have much
> time, I'll probably beat you to that because I really want to push this
> through.

OK.  I'll see about downloading 401 tonight and try your patch if I can
find room to build it.  My hurd partition is starting to get full, so
I'll try building into an nfs-mounted partition which has more space.
(My local ext2fs partitions are too big to use :-( but nfs-mounted
partitions don't seem to have that limit :-).)

> > Although my comments to Branden were in reference to
> > some other boxen I have with an NV1 chipset (and therefore not supported
> > by 4.x), my hurd box has a Diamond Viper V770 card (TNT2 chipset) that
> > should work with 4.x.
> Mmh. Maybe my display trouble is a graphic card issue? I have a Hercules
> Terminator, which is Trio64 based. I use it with the vga driver.
> I will have to test under Linux, so I don't hunt a bug that isn't there...

I should probably test mine under linux, too, just for the config info
if nothing else.  More download time....

> > I've looked at the 3.3 source but I haven't looked
> > at the 4.x source yet nor have I fooled with Branden's 4.x packages so
> > 4.x is new territory for me even if X is not.
> It's not as worth as I feared. Much of X we are concerned about stayed the
> same, one prominent exception being the input device handling, hence the
> problems with the mouse. That part changed drastically.
> One final note. Sometimes it is failing to open the kbd device (interrupted
> system call or even computer bought the farm error). This is probably a bug
> in the kbd translator. Anyway, trying several times usually leads to success
> anyway.
> My primary goal is to get the upstream source in shape and commit the patch
> to the X group and Branden. Then the Debian packaging will be adjusted.

ACK, I'll see if I can keep up with you :-).  First I have to catch up....


[1] An excerpt from the startx output:
-----  Start Cut  -----
XFree86 Version 3.3.6 / X Window System
(protocol Version 11, revision 0, vendor release 6300)
Release Date: January 8 2000
	If the server is older than 6-12 months, or if your card is newer
	than the above date, look for a newer version before reporting
	problems.  (see http://www.XFree86.Org/FAQ)
Operating System: GNU 0.2 i386-AT386 
Configured drivers:
  SVGA: server for SVGA graphics adaptors (Patchlevel 1):
      GeForce DDR, Quadro, ET4000, ET4000W32, ET4000W32i, ET4000W32i_rev_b,
      ET4000W32i_rev_c, ET4000W32p, ET4000W32p_rev_a, ET4000W32p_rev_b,
      ET4000W32p_rev_c, ET4000W32p_rev_d, ET6000, ET6100, et3000, pvga1,
      wd90c00, wd90c10, wd90c30, wd90c24, wd90c31, wd90c33, gvga, r128, ati,
      sis86c201, sis86c202, sis86c205, sis86c215, sis86c225, sis5597,
      sis5598, sis6326, sis530, sis620, sis300, sis630, sis540, tvga8200lx,
      tvga8800cs, tvga8900b, tvga8900c, tvga8900cl, tvga8900d, tvga9000,
      tvga9000i, tvga9100b, tvga9200cxr, tgui9400cxi, tgui9420, tgui9420dgi,
      tgui9430dgi, tgui9440agi, cyber9320, tgui9660, tgui9680, tgui9682,
      tgui9685, cyber9382, cyber9385, cyber9388, cyber9397, cyber9520,
      cyber9525, 3dimage975, 3dimage985, cyber9397dvd, blade3d, cyberblade,
      clgd5420, clgd5422, clgd5424, clgd5426, clgd5428, clgd5429, clgd5430,
      clgd5434, clgd5436, clgd5446, clgd5480, clgd5462, clgd5464, clgd5465,
      clgd6205, clgd6215, clgd6225, clgd6235, clgd7541, clgd7542, clgd7543,
      clgd7548, clgd7555, clgd7556, ncr77c22, ncr77c22e, cpq_avga, mga2064w,
      mga1064sg, mga2164w, mga2164w AGP, mgag200, mgag100, mgag400, oti067,
      oti077, oti087, oti037c, al2101, ali2228, ali2301, ali2302, ali2308,
      ali2401, cl6410, cl6412, cl6420, cl6440, video7, ark1000vl, ark1000pv,
      ark2000pv, ark2000mt, mx, realtek, s3_virge, AP6422, AT24, AT3D,
      s3_svga, NM2070, NM2090, NM2093, NM2097, NM2160, NM2200, ct65520,
      ct65525, ct65530, ct65535, ct65540, ct65545, ct65546, ct65548,
      ct65550, ct65554, ct65555, ct68554, ct69000, ct64200, ct64300,
      mediagx, V1000, V2100, V2200, p9100, spc8110, i740, i740_pci,
      Voodoo Banshee, Voodoo3, smi, generic
XF86Config: /usr/X11R6/lib/X11/XF86Config
(**) stands for supplied, (--) stands for probed/default values
(**) XKB: keymap: "xfree86(us)" (overrides other XKB settings)
(**) OsMouse selected for mouse input
(**) SVGA: Graphics device ID: "Diamond Viper 770"
(**) SVGA: Monitor ID: "ADI MicroScan 5G"
(--) SVGA: Mode "1600x1200" needs hsync freq of 105.77 kHz. Deleted.
(--) SVGA: Mode "1280x1024" needs hsync freq of 107.16 kHz. Deleted.
(--) SVGA: Mode "1800X1440" needs hsync freq of 96.15 kHz. Deleted.
(--) SVGA: Mode "1800X1440" needs hsync freq of 104.52 kHz. Deleted.
Warning: The directory "/usr/X11R6/lib/X11/fonts/Speedo/" does not exist.
         Entry deleted from font path.
Warning: The directory "/usr/X11R6/lib/X11/fonts/Type1/" does not exist.
         Entry deleted from font path.
Warning: The directory "/usr/X11R6/lib/X11/fonts/freefont/" does not exist.
         Entry deleted from font path.
Warning: The directory "/usr/X11R6/lib/X11/fonts/sharefont/" does not exist.
         Entry deleted from font path.
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/misc/:unscaled,/usr/X11R6/lib/X11/fonts/75dpi/:unscaled,/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/"
(--) SVGA: PCI: NVidia Riva TNT2 rev 17, Memory @ 0xe4000000, 0xe6000000
(--) SVGA: chipset:  RIVA TNT2
(--) SVGA: videoram: 32640k
(**) SVGA: Option "dac_8_bit"
(**) SVGA: Using 16 bpp, Depth 16, Color weight: 565
(--) SVGA: Maximum allowed dot-clock: 350.000 MHz
(**) SVGA: Mode "1152x864": mode clock = 137.650
(--) SVGA: Virtual resolution set to 1152x864
(--) SVGA: SpeedUp code selection modified because virtualX != 1024
(--) SVGA: RIVA TNT2: Using hardware cursor
(--) SVGA: Using XAA (XFree86 Acceleration Architecture)
(--) SVGA: XAA: Solid filled rectangles
(--) SVGA: XAA: Screen-to-screen copy
(--) SVGA: XAA: Using 9 128x64 areas for pixmap caching
(--) SVGA: XAA: Caching tiles and stipples
(--) SVGA: XAA: Horizontal and vertical lines and segments
System: `/usr/X11R6/lib/X11/xkb/xkbcomp -w 1 -R/usr/X11R6/lib/X11/xkb -xkm -m us -em1 "The XKEYBOARD keymap compiler (xkbcomp) reports:" -emp "> " -eml "Errors from xkbcomp are not fatal to the X server" keymap/xfree86 compiled/xfree86.xkm'

Fatal server error:
Cannot set event mode on keyboard (Inappropriate ioctl for device)

When reporting a problem related to a server crash, please send
the full server output, not just the last messages

Caught signal 11.

Server aborting...

Fatal server error:
can't reset keyboard mode (Inappropriate ioctl for device)

When reporting a problem related to a server crash, please send
the full server output, not just the last messages

Fatal server error:
can't reset keyboard mode (Inappropriate ioctl for device)

When reporting a problem related to a server crash, please send
the full server output, not just the last messages

Fatal server error:
can't reset keyboard mode (Inappropriate ioctl for device)

-----  Stop Cut  -----
Then several thousand lines of the same before I got the server shut down.

Steve Bowman  <sbowman@frostwork.net> (preferred)
Buckeye, AZ   <sbowman@goodnet.com> <bowmanc@acm.org>

Powered by Debian GNU/Linux and GNU/Hurd <http://www.debian.org>

Reply to: