[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Report on X

I got X working without too many difficulties.  The things I ran into are
(from memory, i.e., everything here is "IIRC ..."):

Had to --force-conflicts with dpkg to install fonts and override the
shellutils conflict (already reported).

Setting up kbd and mouse.  PS/2 mouse works, _but_, have to set up as
settrans -c /dev/mouse /hurd/mouse --protocol=ps/2; -p=ps/2 does not
work (why did I think it would - seems I saw the short form somewhere -
doc error, translator bug, or me barking up the wrong tree?)

Set up kbd as "settrans /dev/kbd /hurd/kbd /dev/kbd" from information on
http://f77.nop.or/jp/doc/XFree86-  MB's instructions
had a different settrans to run.  Haven't checked both ways.

Set LD_LIBRARY_PATH of course (already reported)

Side issues: su was installed without suid bit, so logging on as a regular
user and su'ing to root did not work.  Easy fix, but installation broken

Can only run X as root.  As a regular user, I'm getting am error I
haven't tracked down yet.  Will record error and report back if this
isn't already reported.

dpkg 1.6.999 has a broken "-l" options which just prints "=" forever.

Forgive lack of record-keeping - it was unavoidable.  I'll be unable
to follow this list much for awhile.  Please cc me on any replies.
I will however, try to use the Hurd for daily work and report anything
significant I run into.


Steve Bowman  <sbowman@frostwork.net> (preferred)
Buckeye, AZ   <sbowman@goodnet.com> <bowmanc@acm.org>

Powered by Debian GNU/Linux and GNU/Hurd <http://www.debian.org>

Reply to: