[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Still having booting problems

On Mon, Jan 03, 2000 at 03:04:56PM +0100, Marcus Brinkmann wrote:
> On Sun, Jan 02, 2000 at 11:39:01PM -0500, Neal H Walfield wrote:
> > 8GB IDE drive (pri master)
> > 
> > Linux sits on the SCSI drive, a Hurd partition lives on the first 990MB
> > of the IDE drive.
> > When I boot via the grub in command mode I enter:
> > grub> root (hd1,0)
> I wonder why this works, as pri master is definitely (hd0,0).
> So Grub should not even be able to load the kernel...

Grub believes that the SCSI drive is hd0.  I have used tab completion
to verify this (by examining the geometry and also later when choosing
the kernel and the module).

> > grub> kernel /boot/gnumach.gz -s
> > grub> module /boot/serverboot.gz
> > grub> boot
> > 
> > Note that I do not provide a root argument to the kernel command.
> Have you tried with one (hd0s1) and got the same result?

Yes, with no luck.  Here it won't even boot the kernel.

> > At this point, Mach correctly identifies all of my hardware, the last pieces
> > of which are the COM ports.  As far as I can tell (and this is only an
> > uneducated guess), Mach now hands control over to the HURD by calling(?)
> > /boot/serverboot.
> Yes. serverboot is loaded by Grub after loading Mach. Then Mach is executed,
> and Mach itself executes the module (serverboot) after initialization.
> > Since I did not provide the root argument to the kernel
> > command, serverboot asks for my root device and my server config file:
> [...]
> > Upon accepting the default value, the HURD immediately freezes and will
> > respond only to a hard reset.
> Well, it should not do that :)

That's good news!

> > Needing some kind of output for direction, I tried the documentation in
> > the doc directory to no avail.  I found a program called hello in /hurd
> > and attempted to load that via the severs.boot file with and without a
> > random string argument but with the same success, ie none.
> This won't work as it is a translator. You can try the following:
> $ echo 'main(){printf("Hello World");}' > /tmp/hello.c
> $ gcc -static -o /gnu/boot/hello /tmp/hello.c

Excellent.  Can I use the argument vector here to make a `real' echo command
for more debugging (ie no need to compile 15 of those those with different

BTW, is ext2fs.static suppose to have no output?

> > Currently, I am trying to find the source to serverboot to insert some
> > printf's (printk?) in it, but I am not sure what package to look in or if
> > this is even the correct (a good) approach.
> Well, it did work for me when figuring out such problems. Serverboot is part
> of the Hurd.

I assume that it here refers to the serverboot source.  What package is that in?
When I was poking around, I could not find it.

> Sorry that I could not help your main problem,

Quite alright.  Hopefully what you have told me here will help alot.

Neal Walfield                                              neal@walfield.org
UMass Lowell - Fox 1512                                  Phone: 978-934-5347
                                                           Fax: 603-415-3645
Love is the triumph of imagination over intelligence.
                -- H. L. Mencken

Reply to: