[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Still having booting problems

Hello All,

I hope that everyone had a great New Year.

As per my initial message on this subject (archive/latest/3341), I have
been unable to boot the HURD.  The problem that I am encountering is
identical as far as I can tell to the one described by Tom
(archive/latest/3158) and also referenced by Lars (archive/latest/3347)
with confimation is a private email.

After a lot of thinking and a bit of experimentation, I have not yet come
up with a solution.  My observations follow for those more enlightened
then myself who may have some kind of suggestion:

My configuration is very bare bones:
Xeon 450
196 MB Ram
RAGE 128 16MB Video Card
IDE CDROM (sec slave)
8GB IDE drive (pri master)
On board SCSI AIC-7895
9.1GB SCSI drive

Linux sits on the SCSI drive, a Hurd partition lives on the first 990MB
of the IDE drive.

It is interesting to note that I do not have an ethernet card, nor does Tom,
although he does have an ISDN card, as for Lars, I do not know.

When I boot via the grub in command mode I enter:
grub> root (hd1,0)
grub> kernel /boot/gnumach.gz -s
grub> module /boot/serverboot.gz
grub> boot

Note that I do not provide a root argument to the kernel command.

At this point, Mach correctly identifies all of my hardware, the last pieces
of which are the COM ports.  As far as I can tell (and this is only an
uneducated guess), Mach now hands control over to the HURD by calling(?)
/boot/serverboot.  Since I did not provide the root argument to the kernel
command, serverboot asks for my root device and my server config file:

Partition check (DOS partitions):
 sd0: sd0s1 sd0s2 sd0s3 sd0s4 
 hd0: hd0s1 hd0s2 hd0s3 hd0s4 
com0: at atbus0 port = 3f8, spl = 6, pic = 4 (DOS COM1)
com1: at atbus1 port = 2f8, spl = 6, pic = 3 (DOS COM2)
Root device ``E!!' foes not exist!
Root device name? [`E!!] hd0s1
Server boot script? [/dev/hd0s1/boot/servers.boot]

Upon accepting the default value, the HURD immediately freezes and will
respond only to a hard reset.

I cannot tell if the problem is caused by the serverboot module or the act
of actually loading the ext2fs.static file.  I have tried to reorder the
loading of files in the servers.boot file by loading /lib/ld.so.1 before
loading ext2fs, but that yielded the same output.

Needing some kind of output for direction, I tried the documentation in
the doc directory to no avail.  I found a program called hello in /hurd
and attempted to load that via the severs.boot file with and without a
random string argument but with the same success, ie none.

Currently, I am trying to find the source to serverboot to insert some
printf's (printk?) in it, but I am not sure what package to look in or if
this is even the correct (a good) approach.

Any guidance in this matter would be greatly appreciated!


Neal Walfield                                              neal@walfield.org
UMass Lowell - Fox 1512                                  Phone: 978-934-5347
                                                           Fax: 603-415-3645

Reply to: