[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Still having booting problems

On Sun, Jan 02, 2000 at 11:39:01PM -0500, Neal H Walfield wrote:
> 8GB IDE drive (pri master)
> Linux sits on the SCSI drive, a Hurd partition lives on the first 990MB
> of the IDE drive.

> When I boot via the grub in command mode I enter:
> grub> root (hd1,0)

I wonder why this works, as pri master is definitely (hd0,0).
So Grub should not even be able to load the kernel...

> grub> kernel /boot/gnumach.gz -s
> grub> module /boot/serverboot.gz
> grub> boot
> Note that I do not provide a root argument to the kernel command.

Have you tried with one (hd0s1) and got the same result?

> At this point, Mach correctly identifies all of my hardware, the last pieces
> of which are the COM ports.  As far as I can tell (and this is only an
> uneducated guess), Mach now hands control over to the HURD by calling(?)
> /boot/serverboot.

Yes. serverboot is loaded by Grub after loading Mach. Then Mach is executed,
and Mach itself executes the module (serverboot) after initialization.

> Since I did not provide the root argument to the kernel
> command, serverboot asks for my root device and my server config file:
> Upon accepting the default value, the HURD immediately freezes and will
> respond only to a hard reset.

Well, it should not do that :)
> Needing some kind of output for direction, I tried the documentation in
> the doc directory to no avail.  I found a program called hello in /hurd
> and attempted to load that via the severs.boot file with and without a
> random string argument but with the same success, ie none.

This won't work as it is a translator. You can try the following:

$ echo 'main(){printf("Hello World");}' > /tmp/hello.c
$ gcc -static -o /gnu/boot/hello /tmp/hello.c
> Currently, I am trying to find the source to serverboot to insert some
> printf's (printk?) in it, but I am not sure what package to look in or if
> this is even the correct (a good) approach.

Well, it did work for me when figuring out such problems. Serverboot is part
of the Hurd.
Sorry that I could not help your main problem,

Reply to: