[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Attempt to acces block outside partition


I was today trying to install the HURD.  I followed the instructions from
http://www.pick.ucam.org/~mcv21/hurd.html of today and downloaded everything

I made a partition, placed all below cyl 1024 to avoid booting problems.. I
set it to 83, and run the latest debian potato mke2fs (from
e2fsprogs_1.15-2) with "-o hurd".

It seemed to work fine.  I could mount the partition, the cross-install
script had no objections whatsoever.  When booting up the GRUB from the
boot-disk, it recognised the partition as ext2fs.  But then, when trying to
set the "kernel=/boot/gnumach ...", it complaines over "Attempt to acces
block outside partition", and fails.  I've tried setting root in grub to my
linux partition, and it reads it perfectly.  I can still mount my hurd
partition in linux and read it without any errors.  I even tried copying the
gnumach.gz and serverboot.gz to my linux partition and setting grubs root to
that one, letting it read the kernel (wich it does with no complains) and
the kernels root to my hurd partition, but the kernel panics out...

I have run e2fsck on it, with -f; no complaints..

What now?  Can it have anything to do with the "-o hurd" in the mke2fs?  Or
can the script have done anything so that GRUB don't like it, while it has
no problems with my older linux partition?

Regards, Fredrik

Reply to: