[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


On Fri, 3 Sep 1999, Pontus Lidman wrote:

> On Fri, 3 Sep 1999, Juli-Manel Merino Vidal wrote:
> > Hi all,
> > 
> > I've downloaded all the hurd packages mentioned in 'cross-install' and
> > I've installed hurd with it to hd1s1.
> > 
> > The disk is about 520 mbs. It has 528 cilinders. In linux fdisk I create a
> > single partition from 1 to 528. Grub is unable to read that partition. It
> > determines the filesystem ext2 correctly but says when reading the kernel:
> > 'Unable to access block outside partition' or something. I've decreased
> > the last cilinder to 500 instead of 528 and it works fine.
> That's right, the maximum size of the HURD partition is limited. I think
> it can currently only handle a maximum of 1GB because it maps the disk to
> memory and it can only address 1GB.

But the disk is less than 1GB... only 520 mbs.

> > Booting hurd the first time (single-user mode), I run native-install. The
> > first error is in libc configuration when ask for timezone. It shows an
> > error first, and then, asks 'Number:'. What should I say here ? (I'm in
> > spain). I've put a random timezone. Then, hurd says that it will run dpkg
> > twice to set up pendent packages. Ok. The first time, it shows a lot of
> > errors (as the script warns), but when running the second time, it does
> > nothing. It says 'Setting up <package>...' and stays there (I've
> > redownloaded all the packages to see if that was a download error). It
> > always stop in the first package, so, I can do nothing more!!!
> I had exactly this problem when I had created the HURD partition with a
> too recent version of mke2fs, from e2fsprogs 1.15. After downgrading to
> 1.12, it worked. If you use 1.15 you _must_ downgrade because there will
> be a lot of other problems too otherwise.

OH!! It works now!
Is that a bug of the hurd?

> > I've downloaded the tarball to see if it goes better that packages. I
> > untar it and it goes worse! It is unable to configure anything. When
> > native-install is run, it configures first awk and libc, but it's unable
> > to do it. And it stays in the same place when running the second time
> > dpkg as I said before.
> Correct the above and try again with the .deb's, it works every time for
> me now.

And I had to copy the new native-install to the tarball. Well, I've
deleted the large tar.

Many thanks, bye.

> Regards,
> Pontus
> -- 
> Pontus Lidman, pontus@mathcore.com, Development & support manager
> No matter how cynical you get, it's impossible to keep up.
> Scene: www.dc-s.com | MUD: tyme.envy.com 6969 | irc: irc.quakenet.eu.org
> -- 
> To UNSUBSCRIBE, email to debian-hurd-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Juli-Manel Merino Vidal
jmmv@mail.com - http://jmmv.cjb.net
        >>> Running Debian/GNU Linux 2.2

Reply to: