[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: native-install problem

On Sun, Aug 01, 1999 at 09:05:09AM +0200, Gerhard Poul wrote:
> I just make sure that /libexec/runsystem is properly updated.
> ./native-install: line 127: syntax error near unexpected token `'m!^/hurd/(.'
> ./native-install: line 127: `fstype=`fsysopts / | perl -ne
> 'm!^/hurd/(.*?)\.static.*?([^\s]*?)$!; print $1:'`'
> sh-2.01#

> I don't really know why this happens because the code looks okay...

Yeah, I am confused. I never saw this error.
This error is from bash, which version did you use? Does it work to escape
the parentheses?

> (I've now tried to install it several times with 19990505 but it doesn't
> work. why??)

The native-install script inside the tar file had an error, please use the
latest one from the web page and try again

ftp://alpha.gnu.org/pub/gnu/hurd/contrib/marcus/native-install (is an older
version if the latest does not work)

> In the past it really worked... hmmm... - I'll now try it with 19990104.

NOOOO!!! This version is really old and should be removed. I will do it
next time I go online. It's very buggy.

The fstype thing is really not very important. If this is the only error,
ignore it and set up /etc/fstab manually.


`Rhubarb is no Egyptian god.' Debian http://www.debian.org   finger brinkmd@ 
Marcus Brinkmann              GNU    http://www.gnu.org     master.debian.org
Marcus.Brinkmann@ruhr-uni-bochum.de                        for public  PGP Key
http://homepage.ruhr-uni-bochum.de/Marcus.Brinkmann/       PGP Key ID 36E7CD09

Reply to: