[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: single user mode

On Mon, Jan 25, 1999 at 12:25:54AM +0000, M.C. Vernon wrote:
> On Sun, 24 Jan 1999, Stephen Crowley wrote:
> > I'm new to hurd but I'm interested in helping out with the port, just got it
> > installed an hour ago and had a few questions. First, how do I setup tcp/ip?
> > Second, Is there a way to boot into multi-user mode or does it not work yet?
> > And last, why does libc6 have such a weird name, libc0.2 ?
> See the idiot's guide (from pick.sel.cam.ac.uk) for setting up the network
> (do this in single-user mode). Just lose the -s flag when booting to boot
> multi-user.

Hmm, it seems the idiot's guide is a little outdated but it was still useful. 

-- snip --
cd /dev 
./MAKEDEV dev1 dev2 dev3

First MAKEDEV says it can't find /proc/devices then it says it doesn't know
how to create dev1 or any of the others.

Also, when running native-install I get about 50 erros during dpkg --pending
--configure "No such file or directory: /dev/fd/4" which /dev/fd is a
symlink to /proc/fd, but there is nothing there. Did I miss something?

I've tried two different methods of installation, the first time I tried
just extracting gnu-xxx.tar.gz into /hurd, but I couldn't get it to boot
into multi-user mode (single worked fine). Then I tried downloading all 
the debs and running cross-install, it installed fine but native-install 
totally choked with the problems mentioned above.

Is there any updated documentation for this or could someone please help me
get started? This is really frustrating.


Stephen Crowley                 crow@debian.org, stephenc@wf.net
-* Finger crow@va.debian.org for my public key.	PGP#22714B25  *-

Reply to: