[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

rp2470 strange serial console behaviour

On 12/04/2017 03:54 PM, Helge Deller wrote:
Not sure if console output on a serial port of an rp3440 or related
machines needs to be "consumed" by a terminal to continue. But I've
seen something similar on my rp2470 (with GSP), where I needed to
hit the enter key multiple times to continue the boot process, each
time another few messages would appear on my terminal, but no
output and no progress if I I didn't hit the enter key. Systemd was
already running at this time. Strange behaviour.

Yes, I see this strange behavior as well. I think it's caused by

Later I remembered that I also tried without systemd in the past, and it still happened, although I needed to perform much less keystrokes to finish booting with System V init compared to systemd. But still, the machine "hanged" (e.g. no sshd running) without manual intervention. I today again tried with systemd removed as per [1], but same situation as in my memory.

[1]: http://without-systemd.org/wiki/index.php/How_to_remove_systemd_from_a_Debian_jessie/sid_installation

A workaround to get the rp2470 booting through automatically and still
have a console running on ttyS0 after the boot has finished, is to use two console statements in the kernel command line and place the serial console first, e.g.:

[...] console=ttyS0,9600n8 console=tty0 [...]

The last console statement will win.

But systemd will evaluate both console statements and after the boot is completed there's a getty running on the serial console. With System V init the serial console needs to be configured in `/etc/inittab` AFAIR.

It's still a workaround and one cannot follow all of the console messages, but at least the machine boots through automatically.


Reply to: