[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: autoconf stalls while checking "atomic builtins for 64 bit data types"

John David Anglin wrote...

> Possibly, installing the current Debian kernel from
> unstable would resolve the problem.

No avail. Using the linux-image-4.12.0-2-parisc package, the behaviour
is quite the same. There is however not even a CONFIG_64BIT option in
/boot/config-4.12.0-2-parisc. In vanilla kernel, this option becomes
visible only once the "Processor Type" is changed away from the value
"PA7000/PA7100" (CONFIG_PA700) Debian uses, to "PA8000 and up"
(CONFIG_PA8X00) - a setting that worked fine for me in the past years.

Also, I tried to find when the rsyslog build last succeeded, and
unfortunately could not find any sign it ever did in the past years. So
when I said "since July", count this as a memory error.

My wild guess is the code[which?] uses certain instructions the CPU
cannot handle. For reference, here is /proc/cpuinfo:

 processor       : 0
 cpu family      : PA-RISC 2.0
 cpu             : PA8600 (PCX-W+)
 cpu MHz         : 552.000000
 capabilities    : os32 os64 nva_supported (0x03)
 model           : 9000/785/C3600
 model name      : Allegro W+
 hversion        : 0x00005cf0
 sversion        : 0x00000481
 I-cache         : 512 KB
 D-cache         : 1024 KB (WB, direct mapped)
 ITLB entries    : 160
 DTLB entries    : 160 - shared with ITLB
 bogomips        : 1099.36

But I could use an idea where to look next. Compiler? Kernel?


Attachment: signature.asc
Description: Digital signature

Reply to: