[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [parisc-linux] -pie is broken on hppa

seb@frankengul.org a écrit :
> On Mon, Jun 11, 2007 at 03:03:44PM +0200, Aurelien Jarno wrote:
>>> 1- glibc builds with the linuxthread and not nptl. This lead to a missing
>>> symbol (__librt_multiple_threads) which let me think the activation of linuxthread
>>> maybe bad.
>>> The invokation is --enable-add-ons=libidn,ports linuxthreads. This part looks highly
>>> suspicious to me.
>> Building with linuxthreads is normal. The NPTL add-on currently breaks
>> the ABI for libpthread. This has to be fixed before we can really using it.
>> Note that I have the exact same build error with a 64-bit kernel, but
>> not with a 32-bit kernel. Also the glibc was building successfully on a
>> 64-bit kernel until very recently. I guess the change from
>> linux-kernel-headers to linux-libc-dev (and with it a change from 2.6.18
>> to 2.6.21 headers) has triggered the kernel bug, just like it has
>> triggered the "df bug" (#427395).
> I have the error while building on a 32bit kernel. Don't know why.
> The point I was trying to make is the configure option should be :
> 	--enable-add-ons=libidn,ports,linuxthreads
> whereas it is 
> 	--enable-add-ons=libidn,ports linuxthreads
> (note the space between ports and linuxthreads instead of the ',').
> Anyway, event with the correct option, I have the same error at building.
> This makes me wonder when was the last build ok of the glibc ?

While you are right that it probably needs a ',', I don't think that's
our problem.

The last successfull build of the glibc on hppa was two weeks ago, with
version 2.5-9. The exact same version does not build anymore now.

>>> 2- when enabling the nptl add-on, the glibc builds ok but fails some tests. I don't
>>> really know if it is normal or not. How do I know there is regression or not ?
>> You have to compare the list of failed tests to the linuxthreads one. If
>> new tests are failing, you have to investigate why and see if this is a
>> regression or not.
> How can I run all the tests and get a summary ?
> "make check" run the tests but stops at the first failed test.
> Looking at the .out files is informative but I cannot check if they are ok or not for all of them.

Try running make -k check, and look for lines with Error.

  .''`.  Aurelien Jarno	            | GPG: 1024D/F1BCDB73
 : :' :  Debian developer           | Electrical Engineer
 `. `'   aurel32@debian.org         | aurelien@aurel32.net
   `-    people.debian.org/~aurel32 | www.aurel32.net

To UNSUBSCRIBE, email to debian-hppa-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: