[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: wrong kernel...

Well, sometimes a solution to a problem is just to simple (afterwards).

In the end I'm not quite sure (after evereything I tried), but it seems to
be enough to activate the magic Expert Mode in the installation tool.
This means : during the CD-boot and CD-installation process, just choose the
option "BACK" a few times untill the Menu screen appears; Set the
Debconf-Priority to Low. And than, at the right point during installation,
debian-installer will show a list of available kernels on the CD and you can
select the one you need... That's it.
After that stage, further installation was quite straightforward.

For everyone's intrest : before this second stage, apt-get, dpkg, dselect,
chroot and a lot of other things are not installed yet. I only found udpkg,
but it didn't do just what I wanted to.
So, I'd say, don't waste time mounting and searching all directories on your
devices and restarting the CD-installation over and over again : go for the
Expert Mode !

Thanks for the quick response, Joel.



----- Original Message -----
Subject: Re: wrong kernel...

> Meuleman wrote:
> >Hello,
> >
> >I'm trying some to install Debian Linux 2.6.8 hppa Sarge on a HP
9000/C110 PA-Risc machine.
> >I 've downloaded the iso-files and wrote them to a CD-R, which worked
> >I managed to go through the complete installation procedure without to
many concerns.
> >Unfortunately the machine hangs during booting; last message on the
screen is "HP SDC MLC: Registering the system Domain Controller's HIL MLC"
> >
> >I found some info on the Net about this problem, and the solution would
be to install another kernel from the CD (kernel-image-2.6.8 instead of
...2.6.8-smp). Even the way to do it, is explained : using "chroot" and
"dpkg", sometimes "apt-get" commands after entering the Shell in the debian
> >Unfortunately : dpkg, apt, chroot, aptitude and dselect  are "not found"
("/bin/sh: dpkg: not found").
> >
> >
> iirc the first step should be to chroot to your sda disk (the rest dpkg,
> apt-get should be installed on this one)
> did you mount the right disk: iirc sda (iirc the scsi id 5 for linux)?
> did you look for chroot on your cd?
> may be should you try to give the full path: /usr/sbin/chroot
> >Is there a way to force the Debian Install to choose the kernel I want
(the one without -smp) ? Or is there another way to go ?
> >
> >
> >
> obviously ;-)
> may be grab a recent netinstall cd (e.g.
> <http://cdimage.debian.org/pub/cdimage-testing/daily/hppa/current/>)
> in the hope you find easiestly your chroot to install your new kernel?
> Hth,
>     Joel

Reply to: