[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: impossible to upgrade

On Thu, Feb 13, 2003 at 12:00:49PM +0900, Fumitoshi UKAI wrote:
> # uname -a
> Linux fuka 2.4.9-64 #1 Fri Nov 30 20:18:56 MST 2001 parisc64 unknown unknown GNU/Linux
> WARNING: This version of libc6 requires that you be
> running at least a 2.4.19-64 to work properly.
> Earlier kernels did not provide the proper functionality
> in order for the system to be stable.
> So, installing kernel-image-24.19-64 requires that libc6 (>=2 3.1-1) is
> already installed, but that is what to do after kernel-image-2.4.19-64
> installed.


> The problem here is that libc6 refuses to be installed on older
> kernel.  How dangerous new libc6 running on old kernel?

This is answered above: "Earlier kernels did not provide the proper

> If it's not so dangerous, it's better to accept to be installed
> but warn that user must reboot immediately after all packages upgraded.
> Is there any problem in this way?

Yes, warnings aren't good enough.

> Anyway, I'm considering to use snapshot.debian.net to upgrade packages 
> little by little.  Does anyone know that safe ugprade path?

Personally, I would try force install the kernel-image-24.19-64 package,
reboot, and then let dselect clean up the remaining mess.
No promises that will actually work since I haven't done it.


Reply to: