impossible to upgrade
Today, I try to upgrade hppa debian box, but I can't.
# uname -a
Linux fuka 2.4.9-64 #1 Fri Nov 30 20:18:56 MST 2001 parisc64 unknown unknown GNU/Linux
# dpkg -l initrd-tools dash ash 'libc6*'
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
un initrd-tools <none> (no description available)
No packages found matching dash.
un ash <none> (no description available)
ii libc6 2.2.5-14 GNU C Library: Shared libraries and Timezone
un libc6-bin <none> (no description available)
iU libc6-dev 2.3.1-11 GNU C Library: Development Libraries and Hea
un libc6-doc <none> (no description available)
un libc6-i586 <none> (no description available)
un libc6-i686 <none> (no description available)
un libc6-v9 <none> (no description available)
un libc6.1 <none> (no description available)
Now, libc6 in debian archive is 2.3.1-11, but this version of libc6
checks whether kernel version is 2.4.19-64 or later at preinst time
(Reading database ... 13321 files and directories currently installed.)
Preparing to replace libc6 2.2.5-14 (using .../libc6_2.3.1-11_hppa.deb) ...
WARNING: This version of libc6 requires that you be
running at least a 2.4.19-64 to work properly.
Earlier kernels did not provide the proper functionality
in order for the system to be stable.
dpkg: error processing /var/cache/apt/archives/libc6_2.3.1-11_hppa.deb (--unpack):
subprocess pre-installation script returned error exit status 1
So, I try to install kernel-image-2.4.19-64, but it has the following
Depends: initrd-tools (>= 0.1.6), fileutils (>= 4.0), modutils (>= 2.3.12)
Depends: coreutils | fileutils (>= 4.1.9) | stat (>= 3.0), cpio, cramfsprogs, dash | ash, modutils (>= 2.3.13), util-linux (>= 2.11b-3)
Pre-Depends: libc6 (>= 2.3.1-1)
So, installing kernel-image-24.19-64 requires that libc6 (>=2 3.1-1) is
already installed, but that is what to do after kernel-image-2.4.19-64
installed. Other packages that initrd-tools depends on also have
dependency to newer libc6 (>= 2.3.1-1) that I installed currently (2.2.5-14).
No way to upgrade?
The problem here is that libc6 refuses to be installed on older
kernel. How dangerous new libc6 running on old kernel?
If it's not so dangerous, it's better to accept to be installed
but warn that user must reboot immediately after all packages upgraded.
Is there any problem in this way?
Anyway, I'm considering to use snapshot.debian.net to upgrade packages
little by little. Does anyone know that safe ugprade path?