[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't compile kernel 2.4.18 for d class

> 1) I've tried to reinstall libc6-dev, but as it is off the cd it is at 
> 2.2.5-6 which depends on libc6 being 2.2.5-6 which it isn't because I've 
> upgraded it to 2.2.5-14.3. what is the easiest way out of this situation? 
> downgrade libc6 (how? given that it will break everything else) or upgrade 
> libc6-dev to a later version (which require other dependancies - no 
> internet access.

Why would downgrading libc6 break your box? If programs required a
spcecific version then they'll get uninstalled when you downgrade. I've
downgraded glibc many times (but I no longer have any fear of glibc :)

> 2) Out of interest how did the information provided lead you to identify 
> libc6-dev as the missing link?

All those are required target architecture headers. Work with it long
enough and you'll recognize them...

If you are going to do development work you should probably run:
apt-get install build-essential

Methinks that this gets installed normally depending on what you chose
in tasksel?


p.s. Nice email address.

Reply to: