[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.6 install report -- session mgmt problems

On Thu, 2004-04-29 at 08:46, Tim Otten wrote:
> I've just installed GNOME 2.6 on a powerpc. My sources.list looks like:
> deb http://debian.lcs.mit.edu/debian/ unstable main non-free contrib
> deb http://non-us.debian.org/debian-non-US unstable/non-US main contrib non-free
> deb http://debian.lcs.mit.edu/debian/ ../project/experimental main
> deb http://pkg-gnome.alioth.debian.org/debian experimental main
> I downloaded shared-mime-info from a page mentioned in this list's archive,

It's available from the alioth repository now, but it should really just
get fixed finally...

> and used
> 	apt-get -t experimental install gnome-desktop-environment
> The only major hitch was a conflict involving locale files in libgtop2-2
> (overrode with --force-overwrite).

I haven't uploaded a newer libgtop2-2 because it conflicts with
libgtop2, and I can't build anything against it because of
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=244010 .

> So I tried it out. I killed any loose gnome processes[1] and started GNOME
> with my regular user account (and my old settings). The splashscreen reached
> "Session Manager Proxy" and idled for a few minutes. 

BTW, I removed gnome-smproxy from my session a while ago because it did
more bad than good for me.

> To reduce the number of variables, I made a new (empty) account and tried 
> to start GNOME -- but got the same problem. This time I let it run for 
> quite a while, and I found:
> * The "Session Manager Proxy" step lasts a long time
> * The "Window Manager" step lasts a long time
> * The other steps are quicker
> * The "top" utility shows no active processes during the wait

I also get delays on session startup with my main user, not with another
user though. Haven't tracked down why yet either.

> * When the system does start, windows don't get any decorations
> * A metacity process _is_ running (asleep) after the system starts
> Through trial and error, I eventually found that calling "metacity
> --sm-disable" on my own gets a working window manager. For example, I can
> use an .xsession which says:
> 	gnome-session &
> 	exec metacity --sm-disable
> Some applications are still problematic.  xterm and any GTK1 applications
> will set up processes, but they sleep and don't display anything. Passing
> '--sm-disable' to the GTK1 app's fixes them, but I couldn't get xterm to
> work at all. (The standard GNOME applications, rxvt, and Xine run correctly
> by default.)

I don't have any of these problems. You should check anything related to
session management. Anything interesting in ~/.xsession-errors?

> ii  libc6                       2.3.2.ds1-12 GNU C Library: Shared libraries an

BTW, I'm still running libc6 from testing.

Earthling Michel Dänzer      |     Debian (powerpc), X and DRI developer
Libre software enthusiast    |   http://svcs.affero.net/rm.php?r=daenzer

Reply to: