[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

2.6 install report -- session mgmt problems

I've just installed GNOME 2.6 on a powerpc. My sources.list looks like:

deb http://debian.lcs.mit.edu/debian/ unstable main non-free contrib
deb http://non-us.debian.org/debian-non-US unstable/non-US main contrib non-free
deb http://debian.lcs.mit.edu/debian/ ../project/experimental main
deb http://pkg-gnome.alioth.debian.org/debian experimental main

I downloaded shared-mime-info from a page mentioned in this list's archive,
and used

	apt-get -t experimental install gnome-desktop-environment

The only major hitch was a conflict involving locale files in libgtop2-2
(overrode with --force-overwrite).

So I tried it out. I killed any loose gnome processes[1] and started GNOME
with my regular user account (and my old settings). The splashscreen reached
"Session Manager Proxy" and idled for a few minutes. To reduce the number of
variables, I made a new (empty) account and tried to start GNOME
-- but got the same problem. This time I let it run for quite a while, and I

* The "Session Manager Proxy" step lasts a long time
* The "Window Manager" step lasts a long time
* The other steps are quicker
* The "top" utility shows no active processes during the wait
* When the system does start, windows don't get any decorations
* A metacity process _is_ running (asleep) after the system starts

Through trial and error, I eventually found that calling "metacity
--sm-disable" on my own gets a working window manager. For example, I can
use an .xsession which says:

	gnome-session &
	exec metacity --sm-disable

Some applications are still problematic.  xterm and any GTK1 applications
will set up processes, but they sleep and don't display anything. Passing
'--sm-disable' to the GTK1 app's fixes them, but I couldn't get xterm to
work at all. (The standard GNOME applications, rxvt, and Xine run correctly
by default.)

These problems only affect GNOME sessions. xterm and GTK1 applications work
fine by default if I use an .xsession like:

	exec twm


	metacity &
	exec rxvt

Any idea what's going on? How I might fix this?

More information about my system is included below.

- Tim

[1] Whenever I want to restart GNOME, I close X, kill any loose
	bonobo/gconf/whatever processes, and start X again.
[2] Package versions:
	gnome-session (2.6.1-2)
	metacity (2.8.0-3)
	libgtk1.2 (1.2.10-16)
[3]  Dependency report for gnome-session

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: powerpc (ppc)
Kernel: Linux 2.4.22-powerpc

Versions of packages gnome-session depends on:
ii  desktop-base                0.3.13       common files for the Debian Deskto
ii  libart-2.0-2                2.3.16-5     Library of functions for 2D graphi
ii  libatk1.0-0                 1.6.1-1      The ATK accessibility toolkit
ii  libaudiofile0               0.2.6-3      Open-source version of SGI's audio
ii  libbonobo2-0                2.6.0-1      Bonobo CORBA interfaces library
ii  libbonoboui2-0              2.6.0-2      The Bonobo UI library
ii  libc6                       2.3.2.ds1-12 GNU C Library: Shared libraries an
ii  libesd0                     0.2.29-1     Enlightened Sound Daemon - Shared 
ii  libgconf2-4                 2.6.1-1      GNOME configuration database syste
ii  libglib2.0-0                2.4.0-2      The GLib library of C routines
ii  libgnome2-0                 2.6.1-1      The GNOME 2 library - runtime file
ii  libgnomecanvas2-0           2.6.0-3      A powerful object-oriented display
ii  libgnomeui-0                2.6.1-3      The GNOME 2 libraries (User Interf
ii  libgnomevfs2-0        The GNOME virtual file-system libr
ii  libgtk2.0-0                 2.4.0-4      The GTK+ graphical user interface 
ii  libice6                     4.3.0-7      Inter-Client Exchange library
ii  liborbit2                   1:2.10.0-0.1 libraries for ORBit2 - a CORBA ORB
ii  libpango1.0-0               1.4.0-2      Layout and rendering of internatio
ii  libpopt0                    1.7-4        lib for parsing cmdline parameters
ii  libsm6                      4.3.0-7      X Window System Session Management
ii  libx11-6                    4.3.0-7      X Window System protocol client li
ii  libxml2                     2.6.9-2      GNOME XML library
ii  libxmu6                     4.3.0-7      X Window System miscellaneous util
ii  libxrandr2                  4.3.0-7      X Window System Resize, Rotate and
ii  libxrender1                 0.8.3-7      X Rendering Extension client libra
ii  libxt6                      4.3.0-7      X Toolkit Intrinsics
ii  xlibs                       4.3.0-7      X Window System client libraries m
ii  zlib1g                      1:1.2.1-5    compression library - runtime

-- no debconf information

Reply to: