[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to compile GNOME 1.4 panel applets on Sid now?



On Sun, Feb 02, 2003 at 03:26:02PM -0500, Joe Drew scribbled:
> On Sun, 2003-02-02 at 15:04, Marek Habersack wrote:
> > > > however, libpanel-applet0 does not contain the devel files required to
> > > > compile the code - how can it replace libpanel-applet-dev then? And how do I
> > > > compile the code now?
> > > 
> > > This package has been removed from unstable.
> > I noticed. Still, the libpanel-applet0 package should not replace
> > libpanel-applet-dev. The former does not provide what the latter used to -
> > therefore it is _not_ a replacement and it creates an unnecessary confusion.
> 
> Replaces doesn't mean what it seems you think it does. In particular, it
> does not mean "This package is a replacement for that one" unless
> Conflicts is also present. Anyways, this is moot, since the packages no
> longer exist.
You're right and the parts of policy you quoted confirm that. But my point
is that (even though it's ok according to the policy) the fact the new
package is supposed to replace the older may create a confusion as to its
functionality. If the old package is gone, let it be gone - what is the
point of replacing it in this way?

thanks,
marek

Attachment: pgpsZEY5PkBIw.pgp
Description: PGP signature


Reply to: