[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#419467: Whoa, upstream wontfix?

On Thu, May 10, 2007 at 01:29:58PM +0200, Aurelien Jarno wrote:
> > It's fine for unstable users, but (personally) I don't think it's really
> > living up to expectations for testing, maybe we should ask the release
> > team what they think about the situation.
> > 
> > At least, we should clearly spell this out in the glibc upgrade refusal
> > message (I haven't checked what the current text is like).
> > 
> Note that the check in the preinst is already the second warning. Users
> are supposed to read NEWS files, where it is clearly written that they
> should upgrade their kernel to 2.6 *before* the upgrade to glibc 2.5.

I know, but judging as one of the people supporting users in #debian, I
know that a lot of people do not read NEWS files, they are just helpless
when APT breaks (even if the solution is trivial, most do not understand
the error message "$FOO is uninstallable" or do not know what to do with

I just fear that we'll get lots of people with broken systems who were
relying on "apt-get upgrade" just working on testing, and they will be
quite hard and tedious to support; so if we can present them with a
clear manual solution at the time of the failure (i.e. when they tro
install glibc-2.5 on a 2.4 kernel), that's our best chance to have them
actually pay attention to it and fix it for themselves before they need
help from the community.

OTOH, it could be that the amount of uneducated users still running a
2.4 kernel is negligable, dunno.


Reply to: