[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#420949: New upgrade of libc6 2.5.* renders shells unusable

David Baron a écrit :
> Some more odities that may or may not be relevant:
> With the downgraded (allbeit dependency-problematic) to 2.3*:
> sh run from kpackage fails looking for an .so.# library.

Which one?

> sh run from anywhere else works fine
> bash (sh is simply a symlink to bash) runs fine.
> Opera run from a command line works fine.
> Opera run from a KDE panel button fails.
> With the upgrade to 2.5.*
> sh run from login fails
> sh run from terminal works
> bash fails both ways as I described (but ... sh is simply a symlink to bash).
> Opera does work from the panel button (if I remember correctly--I can get back 
> into kdm/kde by using csh as the user shell. Then I can run sh from the 
> terminal if I want its functionality. Bash, as I described, will not run from 
> the terminal.)

Could you please try to run the two following commands and send me the

/lib/ld-2.5.so /lib/libc.so.6

LD_ASSUME_KERNEL="2.6.1" /lib/ld-2.5.so /lib/libc.so.6

  .''`.  Aurelien Jarno	            | GPG: 1024D/F1BCDB73
 : :' :  Debian developer           | Electrical Engineer
 `. `'   aurel32@debian.org         | aurelien@aurel32.net
   `-    people.debian.org/~aurel32 | www.aurel32.net

Reply to: