[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#419481: libc6 fails to upgrade on AMD64 X2



reopen 419481
thanks

On Mon, Apr 16, 2007 at 01:19:52PM +0200, Manuel wrote:
> I'm sorry but my antispam system caught up all of your messages and it's 
> taken a while for me to be aware of them. I hope it won't happend ever 
> again.

  I'm glad

> >was it the error the first time you tried to install ?
> 
> Yes. Actually I've also tried with the previous 2.5 glibc versions from 
> experimental and same result.
> 
> >does it segfaults with a debian kernel (such as 2.6.18 or .20) as well ?
> 
> I also ckecked the segfault with 2.6.19 & .20 vanilla kernel. I'll try to 
> test it for a debian one as soon as possible.
> 
> >Do you run selinux or any particular stuff ?
> 
> Not the case.
> 
> >ould you give your /etc/nsswitch.conf please ?
> 
> Unfortunately I cannot reach the machine right now, I'll report it later 
> (but I've never touched such a file). Also, I'll try to setup a chroot 
> system with just this news libs to isolate the problem (if I manually 
> install them in the root system, the init process segfaults at the 
> beginning).
> 
> More info: not a single problem with other x86 and x86_64 systems (but 
> neither of them are SMP).

  I own and mad64X2 too, and it worked flawlessly. You will need to run
the preinst/postrm in '-x' mode to see what happens, if that's bash that
segfaults, or a subcommand.

  (edit your /var/lib/dpkg/info/libc6.postinst and set the #! line to sh
-x instead of plain sh).

-- 
·O·  Pierre Habouzit
··O                                                madcoder@debian.org
OOO                                                http://www.madism.org

Attachment: pgpVU7cBuU8b9.pgp
Description: PGP signature


Reply to: