[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#328440: libc6/NIS broken with bash/ksh/tcsh/sash


I'm having the same problem with new Debian's libc6,
but due to different usage symptoms are different (I
didn't tried to login to NIS accounts, I can expose
problem without it).

For the test, I have "zhinis" NIS user, which is member
of "pwr" netgroup.

If I have "+@pwr" entry in /etc/passwd, tilde expansion
crashes bash:
> ramazan@cherokee:~$ ls ~z
> bash: nss_nis/nis-netgrp.c:79: _nss_nis_setnetgrent: Assertion `malloc_usable_size (netgrp->data) >= len + 1' failed.
> Aborted (core dumped)

although getent works OK:
> ramazan@cherokee:~$ getent passwd zhinis
> zhinis:x:2004:2004:NIS test user Z:/home/zhinis:/bin/zsh4
> ramazan@cherokee:~$ ls ~zhinis
> ls: /home/zhinis: No such file or directory

// pam_mkhomedir.so didn't run yet for this user ;)

If I remove "+@pwr" entry or change it to some
_non-existent_ netgroup, ~-expansion works OK.
// it also works OK if I `/etc/init.d/nis stop`

/etc/nsswitch.conf defines NIS as source for netgroup

The same shit with ksh93, tcsh and sash, although zsh,
pdksh, posh, busybox-static (IMHO irrelevant :)),
mksh and dash work OK.

// Didn't tried osh.

Reply to: