[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#186281: libc6 and libdb1-compat mutual dependency

On Wed, Mar 26, 2003 at 08:50:56PM +0100, A.R. (Tom) Peters wrote:
> On Wed, 26 Mar 2003, GOTO Masanori wrote:
> > Hmm, it's bad.  Circular dependency is happened here.
> >
> > Colin, should we remove "depends: libc6" from libdb1-compat?
> > libc6 and libdb1-compat are "priority: required" files, so
> > removal of depends libc6 does not cause problem, I think...
> Why not remove the dependency on libdb1-compat from libc6 instead?
> I understand that libdb1-compat is a compatibility library for old
> binaries.  What is in that package that the so much more fundamental Unix
> system library needs?

It is necessary for compatibility until the release of sarge. At that
point, libdb1-compat will be lowered to extra and the dependency on it
will be removed from libc6. See the changelogs, and the bugs fixed by
the introduction of libdb1-compat, for details.


Colin Watson                                  [cjwatson@flatline.org.uk]

Reply to: