[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Using optional components in packages

On Mon, Jan 11, 2021 at 05:46:19PM +0100, Sebastiaan Couwenberg wrote:
> On 1/11/21 5:00 PM, Jochen Topf wrote:
> > The current osmium-tool and osmcoastline packages support LZ4-encoded
> > PBF blocks when the liblz4-dev package is available at build time. This
> > can be useful because LZ4 (de)compression is much faster than the
> > default zlib compression. I suggest adding liblz4-dev as build
> > dependency to those packages. You can call "osmium version" or
> > "./src/osmcoastline --version", respectively, to see whether lz4 is
> > compiled in.
>  $ osmium --version | head -3
>  osmium version 1.13.0
>  libosmium version 2.16.0
>  Supported PBF compression types: none zlib lz4
> > Maybe we also want to add liblz4-dev as a suggested dependency for the
> > libosmium2-dev package.
> Suggests don't get installed by default, Recommends do, but Depends is
> used for now because it's not a big nor problematic dependency.
>  $ apt-cache show libosmium2-dev | grep Depends
>  Depends: libboost-dev, libbz2-dev, libexpat1-dev, liblz4-dev,
>   libprotozero-dev (>= 1.6.3), zlib1g-dev

Ah, that explains why I didn't see the dependency in osmium-tool and was
wondering... Looks good to me now.

> > The osm2pgsql package is currently built with Lua support, but not built
> > with LuaJIT support. We recently did some tests and use of LuaJIT can
> > speed up osm2pgsql imports by as much as 2 hours (on an 12 hour planet
> > import). Having this on by default would probably help a lot of
> > osm2pgsql users. LuaJIT is mostly compatible with plain Lua, the stuff
> > where it is not (http://luajit.org/status.html) are rather esoteric
> > cases. I don't see any problem for our use case here.
> > 
> > The biggest problem might be that LuaJIT is not available on all
> > architectures, but as far as I can see it is available on all the major
> > ones supported by Debian.
> > 
> > To enable LuaJIT, the osm2pgsql package needs a build dependency on
> > libluajit-5.1-dev and add the option "-DWITH_LUAJIT=ON" to the cmake
> > command line.
> The luajit package is stuck at 2.1.0~beta3 since stretch, upstream has
> no newer releases, the repo on GitHub is active, but has no newer tags
> either. Doesn't seem like a very healthy project, and hence no a good
> idea to use for the osm2pgsql package.

I have reached out to the upstream developer. We'll see what he says.

Jochen Topf  jochen@remote.org  https://www.jochentopf.com/  +49-351-31778688

Reply to: