[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

iptables, target REJECT

I'm new here, but I hope I didn't oversee any rules which might
offend anyone and I hope as well this question wasn't asked before;
google returned many pages related to REJECT, iptables and debian,
but none of the first 40 results seems to help me. 

I wrote a small firewall-skript based on iptables and wanted 
the default policy to be REJECT. Therefore I entered a line

   root@greed:/home/thorsten# iptables -P INPUT REJECT

which resulted in 

   iptables: Bad policy name

I tried already to load the module ipt_REJECT (modprobe ipt_REJECT), 
which seemed to work properly; nevertheless iptables still returns
the same error message.

Could anyone help me please?

Further information about my system:

My system is a KNOPPIX-based installation (yes, I took the lazy way),
the KNOPPIX CD was based on woody. Iptables (and the whole skript) 
does work properly when I set the default policy to DROP. The kernel
is version 2.4.19.

kind regards
Thorsten Möllers

"Und wer was anderes macht, ist Informatiker."
Dieter Bruegmann in dag°

Reply to: