[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: freeswan on testing/2.4.18 kernel

Noah Meyerhans wrote:

On Fri, Apr 12, 2002 at 06:40:22PM +1000, Brendan J Simon wrote:

The two mahcines have an IP address of 192.168.51 and My /etc/ipsec.conf looks like this (see end of message). I've tried with and without the leftsubnet and rightsubnet settings but I can't seem to get a netmask of in the route tables.

Try telling Freeswan to use transport mode instead of the default tunnel
mode for ESP encapsulation.  Add 'type=transport' to the conn section
for this link.  Don't add any subnet or nexthop lines.

Let me know if this doesn't help you.  I've had no problems setting up
IPsec on local subnets, and can probably find something else helpful for
you if you still need it.

I tried 'type=transport' in the connection section and it had no effect :(
I tried both with the *subnet options commented out and not commented out. No difference.

It's freeswan 1.96 BTW.
Has anyone got 1.96 working from the Debian distro ?
Is it broker ??
I might try the 1.95 stable version from the freeswan site.

Thanks for any advice, suggestions or pointers.
Brendan Simon.

To UNSUBSCRIBE, email to debian-firewall-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: