[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: firewall/webserver combo

  the reason you may not be getting the information your like from 
ifconfig is that your using an interface aliasing syntax. If you we're
to configure your interface as 'eth0' as opposed to 'eth0:0' you would 
get more from ifconfig.


Ken Stanley wrote:
> Paul:
> I have had the exact problem, right down to the cable modem issue. Assuming you
> have support for both these cards fully integrated into the kernel then you will
> want to add an append line to LILO. You can get the exact syntax from the
> Ethernet-HOWTO on your system. If you added your NICs as modules then you can
> load them both like you would load any module. The error you are getting looks
> like either you are not giving all the parameters needed, or something may be
> misconfigured in the kernel (sorry Im not a programmer).
> The solution I came up with so that Cable and Intranet can co-exist is to use
> IP-Aliasing. I let the Cablemodem have eth0, then I added the two lines to my
> rc.local:
> /sbin/ifconfig eth0:0 xxx.xxx.xxx.xxx
> /sbin/route add -net xxx.xxx.xxx.0 eth0:0
> (The x's are obviously my ip address.)
> This may not be what you want, but it has worked for me for almost three weeks
> straight with only one problem. ifconfig does not correctly report the packet use
> for eth0:0, but that is where I use IP Packet Accounting (ipfwadm -A) to
> compensate. ;-)
> - Ken
> Paul Tod Rieger wrote:
> > I'd like to set up a P166 as a webserver connected to a cable modem.
> > I'd also like the system to act as a firewall for my "intranet" (a
> > NeXTstation, a print server, and eventually a w98/Linux box).
> >
> > The P166 has two NICs: RealTek RTL8039 and 3Com 3C900 Combo, both PCI.
> > I'd like to connect the RTL8039 to the cable modem, and the 3C900 to my
> > LAN.  The RTL8039 worked with the cable modem under w95, and the 3C900
> > under Solaris-x86 7 (all on the P166).
> >
> > I did a floppy install of the current/stable/slink base system with all
> > ip-masquerading modules in the kernel.  That went smoothly.
> >
> > But I see error messages when using "ifconfig eth0 ..." both at boot-up
> > and as root: SIOCSIF{ADDR, NETMASK, and BRDADDR}: Operation not supported
> > by device.
> >
> > The cable modem seems to see the RTL8039 as a valid connection
> > (according to its status lights) but not the 3C900 (which is OK).
> >
> > Any ideas on how I can get Linux to at least accept the RTL8039 and
> > eventually the 3C900?
> >
> > Thanks for any help!
> >
> > Tod
> > prie@abl.com
> --
> To UNSUBSCRIBE, email to debian-firewall-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: