[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: multistrap does not find squeeze/stable packages anymore



On Sun, 20 Feb 2011 15:15:55 +0100
Marcus Osdoba <marcus.osdoba@googlemail.com> wrote:

> Hi,
> 
> I'm using multistrap from Squeeze (2.1.7) an put some scripts around
> it:
> http://gitorious.org/dockstar/emdebian-multistrap/blobs/master/multistrap_kirkwood_simplenas.conf

You are explicitly allowing Sid to be referenced, and in the bootstrap
line too, so this will change your package selection every time you
run the script.

# include experimental packages
[Sid]
packages=aufs-tools squashfs-tools

> The main part of the packages are taken from Emdebian/Squeeze, some 
> from Debian/Squeeze and at least one with known bugs in Squeeze is
> taken from Sid.

apt is just trying to resolve dependencies. As soon as you mix an
unstable suite with a stable suite, you can no longer expect repeated
builds to give you the same results each time. Unstable changes all the
time, that's why it's unstable.

If you want reproducible results, create your own repository which
contains exactly the versions you want to add to the stable base.

You should probably also convert the packages you want from Debian to
work as Emdebian Grip (using apt-grip) and put those into the
repository.

Mixing Debian unstable with Emdebian stable is a particularly bad idea
because all the strict dependencies will change - twice a day.

You were lucky for a while - that kind of luck doesn't last. multistrap
cannot solve problems like this. Create a stable repository
containing the mix of packages which you need and you'll get stable
results. 

> Maybe some linkage error after the Squeeze release

No, probably a change in the versions available in unstable.

>, so I
> switched from suite=squeeze to suite=stable. Unfortunatly the same
> problem.

That wouldn't have helped, squeeze is stable now.

> The packages were not found in "stable". I look into the
> Grip pool and it says something different:
> http://www.emdebian.org/grip/dists/
> All packages are well present in squeez/stable 
> (busybox,initramfs-tools,lsof,...).

> I did not change the multistrap configuration, but now the pacakges
> are not found by multistrap.
> 
> Was there a change on the server?

The package data has changed for unstable. It will change twice a day,
every day.

> Is some multistrap option important now, which i didn't set before?

No. It's that you're mixing unstable with stable, so the results will
change constantly.

-- 


Neil Williams
=============
http://www.linux.codehelp.co.uk/

Attachment: pgpPS65MkQ06J.pgp
Description: PGP signature


Reply to: